View Full Version : [CLOSED][1.1] BaseTreeLoader constructor compilation error

18 Sep 2008, 9:53 AM
Just upgrading from 1.0.4 to 1.1 and found the following compilation error immediately:

TreeLoader<ElementModel> loader = new BaseTreeLoader<ElementModel>(
new TreeModelReader());
gives me:

"The constructor BaseTreeLoader<ElementModel>(TreeModelReader) is undefined"

THis compiled just fine in 1.0.4 - any ideas anyone?

FYI, ElementModel extends BaseTreeModel<ElementModel>



Andreas Magnusson
22 Sep 2008, 5:03 AM
I had this code:

RpcProxy<String, List<AppModel>> rpcProxy = new RpcProxy<String, List<AppModel>>()...
which I simply changed to:

RpcProxy<AppModel, List<AppModel>> rpcProxy = new RpcProxy<AppModel, List<AppModel>>()...
and now it works. I don't know where the String argument to RpcProxy came from, possibly an example?
Don't really care since it works now :)

22 Sep 2008, 6:05 AM
I also had similar error and I've just changed:

new BaseTreeLoader<ElementModel>(new TreeModelReader());


new BaseTreeLoader (new TreeModelReader());