PDA

View Full Version : compatible version of Livethread with Ext-2.2



lavanyav
27 Sep 2008, 9:25 AM
I wish to get functionality of an AJAX scroll bar for my datagrid, so have used livegrid(v 0.2).
My current version of Ext is 2.2. Is its ok to use livegrid(v 0.2) with Ext-2.2.

else pls suggest what to use.

Also i face another problem using livegrid, when near limit is 5 and store size is 12 , the scroll bar scrolls infinitely.............even after making the near limit as 100 i face the same prob.

I'm a newbie to ExtJS can someone help?

the code is as follows:


Ext.onReady(function(){

var bufferedReader = new Ext.ux.data.BufferedJsonReader({
root : "empInfo",
totalProperty : "totalCount",
id : "empId"
}, [
{ name : 'empId', mapping : 'empId'}
,{
name : 'empName', mapping : 'empName'
},{
name : 'Age', mapping : 'Age'
}]);

var bufferedDataStore = new Ext.ux.grid.BufferedStore({
reader : bufferedReader,
bufferSize : 100,
autoLoad : true,
remoteSort : true,
proxy : new Ext.data.HttpProxy({
url : 'index.jsp'
})
});

var bufferedView = new Ext.ux.grid.BufferedGridView({
nearLimit : 100,
loadMask : {
msg : 'Please wait...'
}});
var bufferedGridToolbar = new Ext.ux.BufferedGridToolbar({
view : bufferedView,
displayInfo : true
});

var bufferedSelectionModel = new Ext.ux.grid.BufferedRowSelectionModel();

var grid1 = new Ext.grid.GridPanel({
ds: bufferedDataStore,
enableDragDrop : false,
cm: new Ext.grid.ColumnModel([
{id : 'id', header : "EmpId", width: 100, dataIndex : 'empId'},
{header: "EmpName", width: 100, dataIndex: 'empName'},
{header: "Age", width: 100, dataIndex: 'Age'}
]),
sm : bufferedSelectionModel,
loadMask : {
msg : 'Loading...'
},
view : bufferedView,
bbar : bufferedGridToolbar,
viewConfig: {
forceFit:true
},
width: 400,
height: 200,
title: 'EmployeeInformation',
// iconCls: 'icon-grid',
renderTo: document.body
});

});

mjlecomte
27 Sep 2008, 11:46 AM
Again, as said before in the other exact same post, you should post your question in the thread for the extension you are asking about.