PDA

View Full Version : Pleasee help: Cant get columns to move!



alek_mc
24 Apr 2007, 3:36 AM
http://alek-3d.be/whatswrong.gif
The square thats support to move with the mouse stands still. I get first one error message that says: "invalid array length" (prototype.js line 460). There is something about a few undefined variables in a Layer function.
After this error, I get spammed with errors for each mouse move as long as I keep holding down the mouse key: "this.el has no properties" (ext-all.js line 101)

alek_mc
24 Apr 2007, 6:19 AM
bump. anyone please?

tryanDLS
24 Apr 2007, 8:32 AM
Please don't bump threads 2 hours after you post. People will answer questions when they have a) time and b) an answer.

Are you trying to do a drag operation? Use the ext-all-debug-all.js file and try to step thru the code with Firebug. You might also see if you have the same problem if you switch to the yui adapter. If you don't find the solution, please post a sample/link that dups the issue.

alek_mc
25 Apr 2007, 5:34 AM
I discovered the error. We have the wrong version of prototype. Appearently earlier version doesnt support the needed feature (length--) and since we used prototype on other aspects of our site, it was still included even though I tried to use yui-adapter. The result was that it still used prototype. To find out I completely removed prototype and then it worked.

So to sum up for anyone else with this issue. First of all you must use a prototype of version 1.5+ and also if including prototype for other aspects than ext, it will overwrite the yui-adapter.