PDA

View Full Version : The problem about the Ext API



afusky
29 Apr 2007, 12:07 PM
Hi guys ,I got a problem about the Ext API
When i use Ext.grid.Grid
The function just like
getDataSource public function getDataSource()
Returns the grid's DataSource.
Parameters:

None.
Returns:

DataSource
This method is defined by Grid.

But i can't find the DataSource API in Documentation Center?? Where is it?

dfenwick
29 Apr 2007, 12:31 PM
It's under the data tree and it's the Store class. The documentation probably needs a thorough review of some of the older classes to get information in there appropriately.

donalconlon
29 Apr 2007, 3:10 PM
I've started to use the datastore, and would love to see some examples/tutorials of how this works. What happens when you edit a cell and get the red marker thingy; how the store, grid, and view fit together, etc. Would be hugely useful.

dfenwick
29 Apr 2007, 5:26 PM
Examples and tutorials are coming. :) In the meantime there should be examples of that here on the boards.

afusky
29 Apr 2007, 7:30 PM
Thanks guys,seems like there is some class missing in the API.:((

dfenwick
29 Apr 2007, 7:42 PM
Thanks guys,seems like there is some class missing in the API.:((

Could you be more specific? It's hard to have a missing class from your own API. :)

If you mean the documentation, there are a couple classes that are not in the docs yet.

afusky
29 Apr 2007, 9:22 PM
If you mean the documentation, there are a couple classes that are not in the docs yet.
that what i mean....