PDA

View Full Version : [3.x] Grid - horizontal scroll



mjlecomte
22 Apr 2009, 6:35 AM
Am I really the only person in the galaxy (except Animal maybe) that sees a horizontal scrollbar on this page?
http://extjs.com/deploy/ext-3.0-rc1/examples/grid/array-grid.html

Pick a browser, any browser. (I only tested FF3.0.8, IE7).

Animal
22 Apr 2009, 6:41 AM
It's most definitely there:

http://i131.photobucket.com/albums/p286/TimeTrialAnimal/gridscroll.jpg

normanhab101
22 Apr 2009, 6:49 AM
:-/

http://i42.tinypic.com/2cypu6a.gif

jay@moduscreate.com
22 Apr 2009, 6:56 AM
It's not on the mac.

mjlecomte
22 Apr 2009, 7:09 AM
In the images above, the vertical scrollbar appears different.

Is this an OS thing? In my testing, I can NOT reproduce the problem unless the vertical scrollbar is there. Maybe the width of the vertical scrollbar is different on the platform?

mjlecomte
22 Apr 2009, 7:15 AM
If I give a little more room for the scroller problem goes away:



viewConfig: {
scrollOffset: 21
},


Is this what you had in the prior thread Animal, I forgot and can't find it at the moment.

mjlecomte
22 Apr 2009, 7:23 AM
I get "19" if I use this tool:
http://jdsharp.us/jQuery/minute/calculate-scrollbar-width.php

jay@moduscreate.com
22 Apr 2009, 10:17 AM
btw i tested on fx 3.0.9

jay@moduscreate.com
22 Apr 2009, 10:28 AM
I get '15' here.

tryanDLS
22 Apr 2009, 10:47 AM
I only see it on IE6, not FF3.08 or Safari 3.2.2

Animal
22 Apr 2009, 11:55 AM
I only see it on IE6, not FF3.08 or Safari 3.2.2

It's fine for me on FF on Vista too.

It's only on XP that there are big, fat scrollbars.

mjlecomte
22 Apr 2009, 12:13 PM
Can y'all go to that link and post your results, along with OS/browser?

With Jay getting 15 and me getting 19 on WinXP I can see why he had no problems. Seems 2 px larger than the calculated scrollbar width is 'safe'.

ApocalypseCow
23 Apr 2009, 6:30 AM
I get 17
xp pro SP3 & FF3.0.9 / IE 7

mjlecomte
23 Apr 2009, 6:34 AM
I get 17
xp pro SP3 & FF3.0.9 / IE 7

And no scrollbars, correct?

Animal
23 Apr 2009, 6:36 AM
19 on FF 3.0.9 on XP

Animal
23 Apr 2009, 6:40 AM
I just turned all visual styles off in XP, and now that returns 16, so the problem has gone.

jay@moduscreate.com
23 Apr 2009, 7:04 AM
Tim, what OS did you test safari on?

jay@moduscreate.com
23 Apr 2009, 7:05 AM
I just turned all visual styles off in XP, and now that returns 16, so the problem has gone.

Ah - are you talking about the OS themes blue and green?

Animal
23 Apr 2009, 7:15 AM
Yes. Now I'm seeing Windows 3.1 style grey everywhere.

jay@moduscreate.com
23 Apr 2009, 7:18 AM
haha. i think it is more like '95/'98 ;)

http://calebgo.com/blog/uploaded_images/InstallingWindows3.1DosBox_13368/image.png

it would be sick to create a windows 3.1 theme for ext. hahah

syscobra
23 Apr 2009, 7:25 AM
hehe.
What a time... when i bought my first windows 3.1 for workgroups OS lol.
I can try to do the win3.1 theme hehe.
Anyways...
If its a OS thing then it has to be fixed in the code with the Ext.isWindows and make another one as Ext.isWinXPWithFatToolbars

jay@moduscreate.com
23 Apr 2009, 7:38 AM
Ext.wtfIsUpWithWindows ?