PDA

View Full Version : deferredRender: false - tab not rendering as tabpanels active item



nadeemshafi9
24 Apr 2009, 5:45 AM
hello guys

i have a tab panel iside a form inside teh tabs are forms with grids inside them, now what happend was, when i told teh tabpanel that its active item is tab1 it cam up with tab1 activated and rendered but when you flickover to anothewr tab it dosent render, so i done deferredRender: false, this fixed it but made it a bit dodgy on teh css, but now all tabs render when you flick to them but teh active tab dosent render as soon as you see teh tabpanel.


any ideas guys

thanlks

tryanDLS
24 Apr 2009, 6:22 AM
http://extjs.com/learn/Ext_Forum_Help#Posting_a_working_showcase

Please proofread your posts or use a spellchecker! How many times can you mis-spell 'the' in one post?

ThorstenSuckow
24 Apr 2009, 6:31 AM
I have experienced this problem to... in my case with 3 tabs:
Tab 0 : Formpanel
Tab 1: Formpanel:
Tab 2: Ext.FlashComponent.

Now, when I open the app, Tab 0 is rendered just fine. If I click Tab 1, it renders okay, BUT if I open the up and click Tab 2 first, then Tab 1, Tab 1 does not get rendered. I'll attach a test case ASAP.




Please proofread your posts or use a spellchecker! How many times can you mis-spell 'the' in one post?

O.T.
Ah, you can't blame him for that. It happens to me all the time. I know how it reads... more like kitteh-pidgin ;)

nadeemshafi9
24 Apr 2009, 7:44 AM
in teh tab panel api it says use deferredRender: false, if you have forms in your tabs as tabs are rendered individualy on activate, now i used it and it fixes teh glitch but the activeitem the default tab never renderes untiol you flick away then flick back.

and spelling the teh just ingrained its just how it comes out