PDA

View Full Version : Ext 3.0 RC1.1 store baseParam passed as GET



iwtlf
4 May 2009, 6:05 AM
Hi, prior to Ext 3.0 RC1.1 (RC1.0 included) all params/baseParams in store operations were sent as POST variables by default. Now they are sent with the URL as GET.

This will force me to make a good number of changes in my server side code as I am expecting POST variables only. This is also my preference as I like the cleaner URLs and encryption of the variables and I have a number of constraints in my backend that prevent me from mixing GET and POST variables for the same request (and consequently would like to have everything in POST 100% of the time).

Furthermore, Ajax requests still use POST as the default.. is that going to change too?

Also, setting the reader's method variable to POST does not address this.

I'm confused as to why this was changed and what can be done to change it back on my end.

BlueAngel
4 May 2009, 6:21 AM
Hi,

I'm having the same problem even when using



proxy : new Ext.data.HttpProxy({
url : 'store.php?get=store',
method : 'POST'
})
Regards

Nash-T
4 May 2009, 4:12 PM
bump.
Same problem here. Would like to just add
method : 'POST'

crandes
4 May 2009, 5:36 PM
Same here too. Any help would be highly appreciated!

mjlecomte
4 May 2009, 5:55 PM
This was fixed in svn.

grEvenX
19 May 2009, 4:25 AM
Could this be pushed as a quick new RC release, I mean, testing Ext 3.0 with existing apps with this bug makes it almost "impossible".
Or if anyone could post a patch we could use in the meantime here.

MD
19 May 2009, 1:35 PM
The corrected code is in the first post of this thread (http://extjs.com/forum/showthread.php?t=67922). Somehow all the messages previous to that on in the thread got wiped out, but that's the one you're looking for.

MD