PDA

View Full Version : this.selModel Error



djfep
5 Sep 2006, 7:59 AM
I am getting the following js error on the grid:

this.grid.selModel has no properties
grid-min.js (line 65)
grid-min.js (line 65)
grid-min.js (line 68)
grid-min.js (line 4)
grid.html (line 99)
event-min.js (line 1)

I have YUI 0.11.3 and just running the example grid.

These are my includes:

<script type='text/javascript' src='/base/lib/yui/yui/build/yahoo/yahoo-min.js'></script>
<script type='text/javascript' src='/base/lib/yui/yui/build/event/event-min.js'></script>
<script type='text/javascript' src='/base/lib/yui/yui/build/dom/dom-min.js'></script>
<script type='text/javascript' src='/base/lib/yui/yui/build/dragdrop/dragdrop-min.js'></script>
<script type='text/javascript' src='/base/lib/yui/ext/yui-ext.js'></script>
<script type='text/javascript' src='/base/lib/yui/ext/build/grid-min.js'></script>
<script type='text/javascript' src='/base/lib/yui/ext/build/element-min.js'></script>
<script type='text/javascript' src='/base/lib/yui/ext/build/yutil-min.js'></script>
<link rel='stylesheet' href='/base/lib/yui/ext/resources/grid.css'>

I can not find where selectModel is defined. this.selModel = selectModel

Thanks for your help. This looks like a great lib.

jack.slocum
5 Sep 2006, 9:16 PM
The yui-ext.js file includes everything so if you include that you don't have to include anything else.

You weren't the only one with the selModel problem. I will be putting out a maintenance release shortly that will fix it.

Jack

jack.slocum
5 Sep 2006, 9:47 PM
It's up. Let me know if that doesn't correct your problem.

djfep
6 Sep 2006, 1:57 AM
I don't see the yui-ext.js in the new version.

If I use yui.js, util.js, and yui-ext.js from your site everything works great.

jack.slocum
6 Sep 2006, 6:35 AM
I don't see the yui-ext.js in the new version.

If I use yui.js, util.js, and yui-ext.js from your site everything works great.

While getting everything ready to move to sourceforge this morning, I changed around my directory structure a bit. My build script didn't copy the new yui-ext.js to the zip file. Sorry about that. A new zip is up that has the "everything" file. The version on my site had the selModel fix in it, but the version in .31 has a few other fixes/additions. You probably will want to get the latest version.

Jack

djfep
6 Sep 2006, 9:19 AM
That one does the trick. Thanks. This is a great extension to yui.