View Full Version : Beginner Question about missing Window Header Background

6 Jun 2009, 1:39 AM
Hi everyone,

I am new with EXT-GWT and EXT-JS. I am trying to get a basic thing working, but something is wrong with the layout.

I am using INtellij with EXT-GWT and JBoss. I have created a new Module (MyModule)
The MyModule.gwt.xml contains two inherits and one entry point:

<inherits name='com.google.gwt.user.User'/>
<inherits name="com.extjs.gxt.ui.GXT"/>

<entry-point class='com.mycompany.client.MyModule'/>
The entry point (MyModule.java) looks like this:

public class MyModule implements EntryPoint {
public void onModuleLoad() {
Button myButton = new Button("Mein neuer Button");
myButton.addClickHandler(new ClickHandler() {

public void onClick(ClickEvent event) {
Window window = new Window();//Is equal in html div
window.setSize(500, 300);//Establishment highly with width
window.setHeading("success");//Establishment title
window.setPlain(true);//Establishes transparently

My MyModule.html looks like this:

<title>MyModule Application</title>

<meta name="gwt:module" content="com.mycompany.MyModule">
<link rel="stylesheet" href="MyModule.css">
<link rel="stylesheet" type="text/css" href="css/ext-all.css" />

<script type="text/javascript" language="javascript" src="com.mycompany.MyModule/com.mycompany.MyModule.nocache.js"></script>

<h1>MyModule Application</h1>
And the ext-all.css is located inside the css directory, copied from the original ext-js package.

When I run the programm and I press the button the window will appear, but the header (where the title (success) is printed) is without background color. At the demonstration page of ext-js.com the header has a background color. I still can move the window by pressing next to "success", and I can resize the window, but how can I get the header background? [@Firefox]

@IE it is the same result, BUT if I move the window a gray (looks like the shadow of the window) is a lot above the window. Look at screenshot.

Does anyone has an idea?

Many greetings and sorry for my English.


6 Jun 2009, 8:45 AM
Hi again,

I just figured it out. I forgot to include the images, raw-images and legancy direcotries into the project :-)

Sorry for this stupid post, but maybe somebody else will have the same problem anytime in the future.