PDA

View Full Version : BulletPoints showing on tree



incunix
1 Jun 2007, 4:04 AM
Hello,
Having an issue with the tree module. It seems to be showing bulletpoints for the elements etc.. How can I get rid of them.
My TreePanel is within a ContentPanel, could that have something to do with it?

Here is a pic so you know what I mean...

http://dropoff.nodelay.com/uploads/ISSUE1.gif

Has anyone had any experience of this??
Cheers, n.

Animal
1 Jun 2007, 4:39 AM
It's your CSS. Use Firebug to check what styling those elements inherit.

incunix
1 Jun 2007, 4:41 AM
Hey, Animal
Havent changed the CSS files or overridden, but ill have a look anyway.
n.

incunix
1 Jun 2007, 4:54 AM
I dont think it is the CSS as its generating bulletpoint tags!
However, the only thing i can think of is x-tree-root-ct which doesnt exist, but not really the problem.



<div id="tree" class="x-layout-active-content">
<div id="folders-tb" style="width: 198px;">
</div>
<div id="folders" class="x-tree" style="overflow: auto; width: 198px; height: 502px;">
<ul id="ext-gen30" class="x-tree-root-ct x-tree-lines">
<li class="x-tree-node">
<div id="extdd-1" class="x-tree-node-el x-tree-node-expanded x-tree-selected">
<span class="x-tree-node-indent"/>
<img id="ext-gen45" class="x-tree-ec-icon x-tree-elbow-end-minus" src="/dhtml/ext/images/default/s.gif"/>
<img id="ext-gen42" class="x-tree-node-icon" unselectable="on" src="/dhtml/ext/images/default/s.gif"/>
<a id="ext-gen39" tabindex="1" href="#" hidefocus="on">
</a>
</div>
<ul id="ext-gen210" class="x-tree-node-ct" style="visibility: visible; position: static; display: block; left: auto; top: auto; z-index: auto;">
</ul>
</li>
</ul>
</div>
</div>


What you think? Why would it generate bulletpoints?!
n.

Animal
1 Jun 2007, 5:02 AM
You mean <ul>s and <li>s? That's how the default TreeNodeUI creates node elements, and they are styled by Ext's css rules on the class names.

You must be overriding the styling.

Use Firebug's HTML tab, highlight a node, and look at the right pane to see where its styles are coming from.

tryanDLS
1 Jun 2007, 6:05 AM
Are you including individual css files rather than ext-all.css? If so, did you include reset-min.css? This is required b/c it sets the base styles - one of which is ol,ul {list-style:none}

incunix
1 Jun 2007, 6:38 AM
I actually was overriding the base UL style!
Im trying to drop an app im building inside another existing app... so you can imagine how much overriding is going on!

Thankx for your help ;)
n.

gyration
20 Oct 2015, 3:46 AM
Hi Incunix,

Please share your solution. I am having the same issue.

- Gyration