PDA

View Full Version : [CLOSED][3.0rc2] Dialog box zooming in FF when Ext is loaded in inactive tab



grzegorz.borkowski
26 Jun 2009, 6:25 AM
This is rather minor bug, but it doesn't happen in 2.2.1.
Open an Ext based page with dialog box centered on the screen in Firefox. Increase page zoom from default 100% to say 150%. Open new empty tag, such that the tab with Ext is not active. Close the browser and open it again (it must be configured to continue with last session after restart, and remember zoom setting for page: I use No Squint plugin for it, I don't remember if it is the same without this plugin). After browser starts, the active tab is the empty one. Now switch to the tab with Ext application, which was started and rendered "in the bacground", in inactive tab. The dialog box is not centered, and looks strange.

I mention it, because I observed that this didn't happen for 2.2.1. So perhaps something can be fixed for this (though I guess it may be hard to debug, because it if renders in active tab, it displays properly).

To validate, look at this urls: version running on 2.2.1: http://r20358.ovh.net:8080/TimesheetsExt/# and the same code running on 3.0RC2: http://r20358.ovh.net:8080/TimesheetsExt-3.0.RC2/#
Open both in tabs, and open third blank tab, increase zoom, open new blank tab, and close browser. After restarting browser wait until two inactive tabs load, then switch to them. In 2.2.1 dialog is centered. In 3.0 is not

grzegorz.borkowski
26 Jun 2009, 6:31 AM
I've just checked that this doesn't require to restarting browser: it is sufficient if you open those two links in new tab, withouth switching to this tab immediately (default behavior of Firefox's "Open in new tab"). The only condition is that is must open zoomed up or down. You may need to install No Squint for this and set default zoom to e.g. 150%.

evant
26 Jun 2009, 6:38 AM
Please follow these guidelines, it's difficult to understand what you're getting at.

http://extjs.com/forum/showthread.php?t=71015

grzegorz.borkowski
27 Jun 2009, 3:09 AM
Looks like Ext forum has some problems with notifications, because I wasn't notified about your response.

Observed in Ext 3.0.RC2, Firefox 3.0, when the web page has non-standard zoom set (ie. different than 100%)

Steps to reproduce:
1. First install NoSquint plugin for Firefox: https://addons.mozilla.org/en-US/firefox/addon/2592. Restart Firefox for plugin to activate, in plugin options (Tools->Add-ons->NoSquint->Options) set the Primary Zoom Method to "Full Page zoom" and set Default Primary zoom level to 150%.
2. Make sure you have firefox configured to continue last session after browser restart (Tools->Options->Main->Startup->When Firefox starts->Show my windows and tabs from last time)
3. Open this link: http://r20358.ovh.net:8080/TimesheetsExt/# (running on Ext 2.2.1) in one tab, make sure that page zoom is 150%. Wait until it loads, verify that dialog box is centered properly.
4. Open second tab, open this link in it: http://r20358.ovh.net:8080/TimesheetsExt-3.0.RC2/# (running on Ext 3.0.RC2). Again make sure that page zoom is 150%, wait until it loads, verify that dialog box is centered properly.
5. Opend third, blank tab. Then close Firefox.
6. Start Firefox. It should open three tabs, with the blank tab active, and two tabs with Ext application loading in background. Wait a bit until they load and initialize completely.
7. Switch to first tab (Ext 2.2.1 version). Make sure the zoom is 150%. The dialog box is centered.
8. Switch to second tab with Ext 3.0 version. Make sure the zoom is 150%. The dialog box is not centered properly.

As I said earlier, it's not a major bug. But if it worked properly in 2.2.1, it means it can work properly in 3.0 too:)

mystix
27 Jun 2009, 6:49 AM
personally, i'd say this doesn't even qualify as an issue.

you've got an atypical browser setup which relies on a 3rd party browser plug-in -- it'd make more sense to fix things in your application code to handle your edge-case scenario as opposed to trying to hammer a square peg into a round hole.

my 2 cents.

[edit]
as a workaround unique to your situation, you could add a slight delay before centering your dialog.

grzegorz.borkowski
27 Jun 2009, 7:31 AM
Well, partially I agree.
The reason why I post is that it worked properly with 2.2.1, so I consider it as a regression. However, I'm aware that's not a supported configuration, that's why I said it's a minor issue. You may leave it if you wish, it has also low priority on my list.
At least, you are informed about this issue - if somebody has any clue which change in 3.0 could cause it, you may want to fix it.

In the meantime, I'll try to check the delay workaround.
[Update] The delay doesn't change a thing. That's funny, call to center() works properly if the tab is active. If another tab is active and the call is done in background tab, the dialog box is placed improperly. Looks like Firefox bug with zooming feature - it returns different window size in those two cases? Strange.