PDA

View Full Version : [FIXED][3.x] Use example.com / user@example.com instead of domain.com



uwolfer
29 Jun 2009, 4:43 AM
Please change all user-visible strings from domain.com to example.com.

See also:
http://en.wikipedia.org/wiki/Example.com

mystix
29 Jun 2009, 5:03 AM
why is this a bug? /:)

see http://extjs.com/forum/showthread.php?t=71015

uwolfer
29 Jun 2009, 5:14 AM
Ok, I thought the provided information should be enough to fix it. It's IMHO an easy job to just do a search-replace over the source tree...

Version I'm using here is 3.0 RC2. You can see the message in a textfield when setting vtype to email.

I suggest this change since it's recommended by a HTML RFC. Also I think you do not want to promote doman.com, which is a real company.

Condor
29 Jun 2009, 5:26 AM
I agree with @uwolfer.

While this isn't a bug, it's not nice to link to an existing website when there is a url defined for this kind of messages.


Ext.apply(Ext.form.VTypes, {
'emailText': 'This field should be an e-mail address in the format "user@example.com"',
'urlText': 'This field should be a URL in the format "http:/'+'/www.example.com"'
});

VinylFox
29 Jun 2009, 5:34 AM
I went ahead and updated this on the trunk. rev 4587

Should I bother updating the 2.x branch as well?