View Full Version : GWT 1.64 Class not found exception GXT module declaration is.

7 Jul 2009, 5:41 PM
by inserting:

<inherits name='com.extjs.gxt.ui.GXT'/>

in the module file GWT bombs out stating that the class can't be found. All the references to GXT.jar are configured on the run configuration as the project references. The error is:

[ERROR] Line 6: Unexpected exception while processing element 'inherits'
java.lang.NoClassDefFoundError: com/google/gwt/core/ext/Generator

I've already tried to create new projects with the same conclusion. My setup is:

-Eclipse 3.4
-JVM 1.5
-GXT 2.02
-GWT 1.64
-Mac OS X 10.5.7

If I take the inherits for GXT GWT works fine. I'm kind of desperate with this I've gone through the tutorials already and nothing seems to work.

Your help will be greatly appreciated. Thank you for your time.

7 Jul 2009, 6:15 PM
Just looking at my project, I can see that the class com.google.gwt.core.ext.Generator comes from the gwt-dev-linux.jar file. Make sure you have a reference to this JAR file, also its important to note that this is a Google JAR file, not Ext GWT even though the package is com.google.core.ext.Generator, this threw me a bit when I first started looking into this issue

7 Jul 2009, 6:30 PM
I understand but the error is being generated when the GXT module is being added. Where it says line 6 is actually the entry for the inherits.

I checked the libraries are being referenced correctly in both the compiler and in the runtime. Confirmed with the command line panel.

In my case is gwt-dev-mac.jar

7 Jul 2009, 7:12 PM
I see, a quick Google suggests that you must verify a few things:

- gwt-user.jar must be on your classpath
- gwt-dev-<platform>.jar must be on your classpath (in your case gwt-dev-mac.jar)
- Your application's 'src' directory must be on the classpath
- Your application's 'bin' directory should NOT be on the classpath (or if it is, it should come after 'src')
- The 'main' class you run should be com.google.gwt.dev.GWTCompiler

I hope this helps, I got this from here:

8 Jul 2009, 5:11 PM
I found the problem, post in the solution if someone has this problem in the future.

In Mac OS X, Extension jars are put inside /Library/Java/Extensions that's where I copied the gxt.jar, for some reason even though the library was referenced correctly the GWT compiler couldn't find it. Once I moved the jar out of there and put it in ~/Library/gxt and made a new user library GWT was able to find it.

Thank you for your help. This was a tough one.

18 Aug 2011, 7:50 AM
I have successfully prepared a training application as described on the page "Setting Up Your First Ext GWT Project in Eclipse (http://www.sencha.com/blog/setting-up-your-first-ext-gwt-project-in-eclipse/)" and posted it on Google App server at year-1975.appspot.com (http://year-1975.appspot.com/).
However, I absolutely can not run the application locally. The exact same error appears. Library gwt-dev.jar was explicitly added to the file ".?lasspath" by string

<classpathentry kind="lib" path="/Users/safarov/Downloads/Google WebToolkit/gwt-2.2.0/gwt-dev.jar"/>

What else could be the cause of the error?
I also use a computer running Mac OS