View Full Version : Help! I can't even load /docs

7 Jun 2007, 6:53 PM
Hi Folks,

I'm having some very strange and frustrating issues with running extjs in my local apache webserver.

Basically, I see no content (both ie & ff) when going through the webserver. However, when I load the file from the filesystem (eg. C:/Desktop/..) the page loads correctly.

When I'm going to: http://localhost/ext-1.0.1/docs/ all I see is the Loading box with the rotating circle.

In firebug I get 2 errors (pasted below):

1.) missing ) after formal parameters
[Break on this error] Ext.DomHelper=function(){var _1=null;var _2=/^(?:br|frame|hr|img|input|link|meta...
ext-all.js (line 29)

2.) Ext.onReady is not a function
[Break on this error] Ext.onReady(Docs.init, Docs, true);
docs.js (line 114)

Has anyone else seen this?


8 Jun 2007, 8:17 AM
Did you verify your paths to the js files? Look at the script tab in firebug are the ext files loaded?

9 Jun 2007, 8:47 AM
Hi Tim,

Yes, the *.js files are loaded. Just by viewing /docs I see the following js files in the script tab:


Any help would be greatly appreciated


10 Jun 2007, 5:29 PM
Do you think there is a setting i may be missing in my apache conf?

13 Nov 2007, 8:51 AM
a have the same error?

Anyone can help us?

18 Nov 2007, 5:51 AM
Same problem

18 Nov 2007, 7:00 AM
I have seen this issue before (rarely) when there was a config issue with Apache. Open a direct URL to ext-all.js on localhost and scroll all the way to the end of the file. If it is cut off when served over http, but you can verify that the physical file is correct, you are most likely hitting a config limit somewhere in Apache. I've seen this happen once or twice.

The other case where I've seen this symptom was on a public server, and the root cause ended up being a virus that was screwing up the files getting served. :s

2 Feb 2008, 6:28 PM
Ok, I've seen this same corruption problem with many other files I've tried working on on my local Apache server. And the problem (as is so usually the case these days) is NOT with Apache (or even the files we're working with). It's with Windows!

There's a particular note in the win32 Readme for Apache
which states...

Problems Installing or Running Apache 2

If you encounter problems running Apache 2 under Windows, such as corrupted or incomplete file downloads, unexplained error messages, or a conflict with a software firewall, please place the following three directives in your httpd.conf configuration file to see if they eliminate the problems:
EnableSendfile Off (http://httpd.apache.org/docs-2.2/mod/core.html#enablesendfile)
EnableMMAP Off (http://httpd.apache.org/docs-2.2/mod/core.html#enablemmap)
Win32DisableAcceptEx (http://httpd.apache.org/docs-2.2/mod/mpm_winnt.html#win32disableacceptex)
The general problem is that many people install various add-ons to windows (such as software firewalls, virus checkers, etc) that break some of the advanced functionality that Apache uses to speed the sending of files. The above directives turn off the advanced functionality and make Apache fall back to more basic (but slower) techniques. This resolves most, but not all of the potential problems. If you continue to experience problems, be certain that there is no spyware installed on the box, which exhibits exactly the same sorts of flaws (often more obviously).

So, I added the three lines mentioned into my Apache Config (httpd.conf), restarted Apache and voila!!! It worked! (p.s. the same problem/fix also effects the IBM IHS Server, which is based on Apache Source).

Sorry this answer is so long in coming but hopefully it will help others out there.

Mike B

9 Oct 2008, 7:47 PM
Thanks Mike B, this solved my problem....