PDA

View Full Version : Upgrade failed!



Hypercom
13 Aug 2009, 8:35 PM
I failed to upgrade my project from Ext2.0 to 3.0. Here is the error from firebug:
Ext-all-debug.js line280 -- el is undefined

The caller: this.runCallback(callback, scope || node, [node]);
which is located at: Ext-all-debug.js line47768

It seems something was wrong with tree loading, but I have no idea to locate the error, because everything works pretty well in Ext2.0! Please help me!

Animal
13 Aug 2009, 9:33 PM
No idea?

Like setting Firebug to "Break on all errors", and then looking around at what is wrong when it breaks did not occur to you?

How do you write software if you have "no idea" how to debug code?

Hypercom
13 Aug 2009, 10:23 PM
No idea?

Like setting Firebug to "Break on all errors", and then looking around at what is wrong when it breaks did not occur to you?

How do you write software if you have "no idea" how to debug code?


That's exactly what I've already done. Then I got the info that I mentioned!

Animal
13 Aug 2009, 10:53 PM
No.

I mean look around at the code. See what el is being used for. See how it got there. was it pased in? Go back through the call stack to see who originated it.

This is a 5 minute debugging job! 5 minutes.

Work that out in $/hour eny employers out there!