View Full Version : installation issues

16 Aug 2009, 7:16 PM
Hey you guys:
Im a newbi trying to install the gxt on eclipse jee galileo 3.4 but i have a serious problem

I instlled the gwt plugin for eclipse and download the gxt library. Then i followed every step in the setup.txt file like adding the gxt.jar in the buildpath and the classpath, and writting <inherits name='com.extjs.gxt.ui.GXT'/> in the gwt.xml file. But when im runnign the web application it keeps launching the same error.
[ERROR] Line 16: Unexpected exception while processing element 'inherits'
java.lang.NoClassDefFoundError: com/google/gwt/core/ext/Generator
at java.lang.ClassLoader.findBootstrapClass(Native Method)
at java.lang.ClassLoader.findBootstrapClass0(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at com.google.gwt.dev.cfg.ModuleDefSchema$ObjAttrCvt.convertToArg(ModuleDefSchema.java:720)
at com.google.gwt.dev.util.xml.HandlerArgs.convertToArg(HandlerArgs.java:64)
at com.google.gwt.dev.util.xml.HandlerMethod.invokeBegin(HandlerMethod.java:214)
at com.google.gwt.dev.util.xml.ReflectiveParser$Impl.startElement(ReflectiveParser.java:257)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanStartElement(Unknown Source

Does anyone know how to solve it?
should i uninstall eclpise and start everything again ?
should i install another eclipse version ?

I'll appreciate the help.

16 Aug 2009, 7:29 PM
I can tell you now, this IS a classpath problem, double check your classpath...

Switch to the debugger perspective in eclipse, take a look at the Debug view, right click on the running thread, and click on properties, then filter through all the crap in there, you will find the classpath, just make sure its all setup correctly.

16 Aug 2009, 8:03 PM
thnks for the fast answer.

i actually did what you say..... switch to debug view and saw the thread propierties.
But.... what should i look for ? i mean, for me.... everthing looks ok.... no problems in the classpath

"C:\Archivos de programa\Java\jre6\bin\javaw.exe" -Xmx512m -Dfile.encoding=Cp1252 -Xbootclasspath/a:D:\eclipse\gxt-2.0.1\gxt.jar -classpath "C:\Documents and Settings\Camilo\eclipse galileo Proyects\myTest\src;C:\Documents and Settings\Camilo\eclipse galileo Proyects\myTest\war\WEB-INF\classes;D:\eclipse\plugins\com.google.gwt.eclipse.sdkbundle.win32_1.7.0.v200907291526\gwt-windows-1.7.0\gwt-user.jar;D:\eclipse\plugins\com.google.gwt.eclipse.sdkbundle.win32_1.7.0.v200907291526\gwt-windows-1.7.0\gwt-dev-windows.jar;D:\eclipse\gxt-2.0.1\gxt.jar" com.google.gwt.dev.HostedMode -startupUrl MyTest.html -war "C:\Documents and Settings\Camilo\eclipse galileo Proyects\myTest\war" -logLevel INFO -style OBFUSCATED -port 8080 com.Test.myTest.MyTest

should i resintall eclipse without the gwt plugin ??

16 Aug 2009, 10:40 PM
I doubt a re-install would help you out here. I have eclipse 3.5 running with the Google Eclipse Plugin, and it all works just fine.

So obvious question... does D:\eclipse\gxt-2.0.1\gxt.jar exist?

17 Aug 2009, 8:02 AM
yes.. it does exist.

I'll reinstall eclipse without the gwt plugin and see if it works.

another question:
Do you have the eclipse jee ? or jut the basic eclipse ?

17 Aug 2009, 2:34 PM
Im using Eclipse JEE,

also can you please try for me, move the GXT.jar file into your WEB-INF/lib directory, so that after you refresh your Eclipse project, your gxt.jar file will show up in the "Web App Libraries" within the Package Explorer? (Or right click on the project, the click Build Path -> Configure Build Path and add it through there).

Another poster had a similar issue on these forums, (https://extjs.com/forum/showthread.php?p=354277) that I also tried to help with ;) but it turned out that for some 'magic' reason, the OS simply couldnt find the gxt.jar file, so he moved it to a 'better' location and the OS could, for some reason, find it... weird but it worked.


19 Aug 2009, 1:06 AM
but please focus also to the normal gwt files not only on the gxt files to include.