View Full Version : jsbuilder2 error

19 Aug 2009, 12:23 PM
I just got the trunk from SVN and downloaded JSBuilder2 from:


Any ideas?

taras@taras-ubuntu:~/Desktop$ java -jar JSBuilder2.jar --projectFile /home/taras/Desktop/ext3_latest/trunk/ext.jsb2 --homeDir /home/taras/Desktop/deploy/
Loading the 'Ext JS' Project
Loaded 35 Packages
Compressing output files...
Exception in thread "main" java.lang.RuntimeException
at com.yahoo.platform.yui.compressor.JavaScriptCompressor.printSourceNumber(JavaScriptCompressor.java:299)
at com.yahoo.platform.yui.compressor.JavaScriptCompressor.parse(JavaScriptCompressor.java:336)
at com.yahoo.platform.yui.compressor.JavaScriptCompressor.<init>(JavaScriptCompressor.java:533)
at com.extjs.JSBuilder2.compressOutputFiles(JSBuilder2.java:302)
at com.extjs.JSBuilder2.main(JSBuilder2.java:45)

19 Aug 2009, 12:27 PM
I figured out the issue...funny how that happens as soon as you post on the forums huh? Well anyways I nuked Rhino from the package manager in linux and that fixed the issue. I tried that because it seems like it conflicted with the use of Rhino within the jsbuilder2 jar as documented here:

JSBuilder uses the following libraries
YUI Compressor licensed under BSD License

Mozilla's Rhino Project licensed under Mozilla's MPL

JArgs licensed under BSD License

JSON in Java licensed under the JSON License

20 Aug 2009, 1:14 PM
I think ExtJS should use JarJar for it.

28 Aug 2009, 7:40 PM
I found that this (at least in my case) was related to this bug: https://bugs.launchpad.net/ubuntu/+source/openjdk-6/+bug/255149
I switched from openhdk to sun and everything worked fine.
In some cases you can't just simply nuke rhino since other system components may depend on it.
I proper solution (which I can't find because I'm not a java guy) would probably be to defer to the locally packaged rhino dist with JSBuilder2 rather than system lib.

4 Sep 2009, 4:02 AM
this seem to happen with all VMs that have a older version of Rhino included. (For me it happend on Leopard with JDK 1.6)
One workaround that worked for me fine (as i did not need to reconfigure my VM), is to include the JSBuilder JAR temporarily to the endorsed JARs:

java -Djava.endorsed.dirs=. -jar JSBuilder2.jar --projectFile ./build.jsb2 --homeDir .