View Full Version : TreeNode DnD Kills Qtips

17 Jun 2007, 10:21 AM

Not sure how to explain this one. Qtips work fine on my two rendered trees in a BorderLayout upon initial loading. I have a DnD source tree with nodes that can be dragged to the other destination tree for dropping. All is well with the QTips at this point, as long as I stay legal with the DnD.

If I initiate a DRAG on a node in the source tree that has allowDrag: false, the node is draggable with an ICON representing a document, but no Drop zone lights up, which is good, showing this node is NOT droppable. I wonder why it drags in the first place though??? Letting go of the DRAG sees the icon animate back to it's source node.

Now, after this drag attempt on a non-draggable TreeNode, ALL QTips are off. Hovering over a node with QTip shows nothing.

What's up with that? Any hints, tips or ideas most welcome.


18 Jun 2007, 3:36 AM
Is there any custom code anywhere? It seems like something is in fact failing because in my test code, allowDrag does not even allow initiating a drag.

18 Jun 2007, 4:36 PM

We checked the same code on Windows Vista FF2. With that browser, you see a no parking symbol when you try and drag the nodes marked allowDrag: false, indicating they are not draggable. So, this could just be another weirdo behaviour of FF Linux (it seems the default icon for DnD when it is not allowed is not exactly indicative that what you are trying to do is not allowed.

Still.. QTips are killed on both platforms, I tried turning them on with the enddrag event but that is not fired when dragging non-draggable nodes, hence that tip from another post did not seem appropriate.

19 Jun 2007, 4:18 AM
What version are you running?

19 Jun 2007, 11:22 AM
I am experiencing the same behavior using 1.0.1a

This is my tree definition

feedsTreeLoader = new Ext.tree.TreeLoader({dataUrl:urlFeedReader});
feedsTreePanel = new Ext.tree.TreePanel('feeds-tree', {
loader: feedsTreeLoader,
containerScroll: true,

If I try to drag a node that has allowDrag:false, QTips stop displaying in both IE6 and FF (Haven't tested any other browsers).

19 Jun 2007, 3:12 PM
Try it with 1.1 beta 1, I believe this issue has already been fixed.

20 Jun 2007, 5:21 AM

I just tried with 1.1-beta1, and this is the behavior I am seeing,

QTips are turned off after trying to drag a node with allowDrag:false. And they stay off until I expand or collapse any node or any tree...