PDA

View Full Version : Editorgrid + Hide/Show columns problems (v3.0)



Shaguar
31 Aug 2009, 1:22 AM
Hi guys,
since i've updated from version 2.2 to 3.0 i get this error when i want to hide/show specific columns in my editorgrid. (Only the "Show all" button still works).
item.itemId is undefined
index = cm.getIndexById(item.itemId.substr(4));\n

ext-all-debug.js (Zeile 61944)


I get the same error when i click on the "Sort ascending" "Sort descending" buttons, i still can sort the column by clicking on the column header but not that way.

Can someone give me a hint whats going wrong there?

Thx in advance.

Condor
31 Aug 2009, 1:23 AM
Are you using a grid plugin or extension? Those need to be upgraded too!

Shaguar
31 Aug 2009, 1:41 AM
hm, im using CheckColumns plugin and maybe some others too but i thought i'd removed them all but the same error occurs.
I'll give it a new try.

Update:
Yepp, i'm using checkcolumns, filters, search plugin and paging plugin, removed them all but same error.

Condor
31 Aug 2009, 2:26 AM
Any plugin that adds items to the grid header menu needs to be upgraded.

Did you upgrade the filter plugin?

Shaguar
31 Aug 2009, 2:32 AM
no i didnt but as i told, i removed the plugins completly to see if it works. but it didnt.
i can try to update the plugins but it should work without them, shouldnt it?

Update:
I just discoverd that the "Show All" button in the columns selection (visibility) list isnt standard, it must be a plugin too but how can i update or remove this button?

Condor
31 Aug 2009, 2:40 AM
It does work without plugins.

So if it doesn't, it must caused by you not running the original Ext 3 code.

Are you sure you aren't using any plugins, extensions or custom overrides?

Shaguar
31 Aug 2009, 6:09 AM
Ok i've found the problem, it was this extension here
http://extjs.com/forum/showthread.php?t=28832&highlight=gvOverride
but the author of this extension didnt update it for ext 3 and i dont know how to do it manually.

Condor
31 Aug 2009, 6:42 AM
You should ask the author if he is willing to update the extension to Ext 3.0.