PDA

View Full Version : How i can disable the shadow of a tooltip ?



uptodate
9 Sep 2009, 10:48 PM
How can i hide or disable the shadow of a tooltip ?
shadow : false --> not work



new Ext.ToolTip
({
target : e.target
,autoHeight : true
,trackMouse : true
,dismissDelay : 0
,shadow : false
})

uptodate
10 Sep 2009, 11:51 PM
the problem still exist

Condor
11 Sep 2009, 12:33 AM
Use:

new Ext.ToolTip({
target: e.target,
autoHeight : true,
trackMouse: true,
dismissDelay: 0,
shadow: false,
floating: {
shadow: false,
shim: true,
useDisplay: true,
constrain: false
}
});

mixer80
11 Sep 2009, 1:04 AM
Hi,
my problems start when I test my application on IE ( 7 and 8) .
When I mouse over on a action, the tooltip appear in a strange mode.
See the attach..

My tip is trunked in 2 separated div with a trasparency in the center and in the bottom.
I see x-tip class with no bg... but it appear like "shadow-lr.png" zoomed as bg of the div
I try to fix this IE problem like this:

.x-tip {
background : #e9f2ff ;
}

But the result is not correct.. because borders are wrongs..
see the picture.

My fix is incorrect can someone help me?

p.s.= in Firefox all ok ....

Thanks at all

Condor
11 Sep 2009, 1:22 AM
It looks like a css problem. Could any of your own css (or markup in the tip text) cause this?

mixer80
11 Sep 2009, 2:10 AM
Yes Condor... it's very probably...
My application is under a viewport..
the div with class "x-tip" eredit properties from title viewport class.


.title_viewport {
background: #34537E;
background-repeat: repeat-x;
text-align: left;
vertical-align: middle;
padding-right: 10px;
font-family: "Trebuchet MS";
font-size: 18px;
height: 35px;
}
if replace this code with:


.title_viewport {
background: #34537E;
/* background-repeat: repeat-x;
text-align: left;
vertical-align: middle;
padding-right: 10px;
font-family: "Trebuchet MS";
font-size: 18px;
height: 35px;
*/
}run better than last time.. not perfectly but better...
see the attach..

Now my title vieport lost all properties like text-align,
padding-right, font-family ,font-size ,ecc...
For me is a disaster...
~o)

Maybe I must erase tooltip from my code..
:s

Thanks for Help

uptodate
11 Sep 2009, 3:11 AM
thx condor this helps