PDA

View Full Version : Ext looks different



Air_Mike
23 Sep 2009, 12:30 AM
Please help,

I'm working on project with Java/JSP (Tomcat 6.0, Java 1.6), and for my application layout I use Ext (ofcourse :))

For start, this isn't my first project with Ext. I developed several application starting from Ext 1 to Ext 3 and I've never had this problem.

On my local computer (Windows XP, running Tomcat 6.0 (from Eclipse) and Java 1.6) application looks like it should, but when I deploy it to test server (also running Windows with Tomcat 6.0 and Java 1.6) application doesn't look the same (form button are wrongly align, combobox looks strange, column layout title background are not fill)

Even when I run application from other computer entering URL to my local computer problem is the same.

I must mention that I use IE8 because its one of the requirements (application also use couple of applets)

I'm wondering what could be the problem and If anyone experienced something similar.

Please help. In a few days I have presentation and I want application to shine in all its Ext glory :)

I can sent pictures if it helps.

Thank You.

evant
23 Sep 2009, 12:32 AM
Make sure the css files are included properly. Also make sure there's no "conflicting" css on the deployment server.

Air_Mike
23 Sep 2009, 1:36 AM
Thank You for reply.

I have only three css files:
- ext-all-notheme.css,
- xtheme-blue.css
- main.css (which contains only few lines).

That was my first check, along with setting BLANK_IMAGE_URL properly.

If I put aside deploying on development server, this problems occurs if I run application from another computer using url to my localhost server.