PDA

View Full Version : is BasicDialog workable on BorderLayout?



wos
28 Nov 2006, 8:18 PM
http://img135.imageshack.us/img135/8418/untitledek7.jpg

hi guys,

i getting myself bang to the wall again, as you can see, i trying to use BasicDialog on BorderLayout,
what i did is, puttting a button on one of the tab panel, when i click the button...the dialog appear and seem join together with borderlayout,

Animal
29 Nov 2006, 12:17 AM
Use a LayoutDialog. See docs for details.

wos
29 Nov 2006, 12:47 AM
still no joy,

this is what i get after so many attempts :( and i use this
http://www.yui-ext.com/deploy/yui-ext/examples/dialog/layout.html
http://www.yui-ext.com/deploy/yui-ext/examples/layout/complex.html
as example

http://img86.imageshack.us/img86/3024/take2ey8.jpg

Animal
29 Nov 2006, 2:07 AM
Make sure you create the dialog's Element correctly:



var myLayoutDialog = new YAHOO.ext.LayoutDialog(YAHOO.ext.DomHelper.append(document.body,
{
tag: "div",
id: myDialogId, // You must set this!
style: { visibility:"hidden" },
cls: "ydlg",
children: [
{
tag: "div",
cls: "ydlg-hd",
html: "Dialog Title"
},
{
tag: "div",
cls: "ydlg-bd"
}]
}, true), this.layoutConfig);

wos
29 Nov 2006, 2:45 AM
i created it not in that way, i created it in design view, but the elem Id is correct

Animal
29 Nov 2006, 2:51 AM
We're going to have to see your code.

wos
29 Nov 2006, 2:52 AM
ok, who should i sent to?

Animal
29 Nov 2006, 2:57 AM
Post a link to a page we can run. I know it can be a hassle, but it's the best way.

wos
29 Nov 2006, 2:59 AM
ok, i will ready the links for you to review

wos
29 Nov 2006, 3:30 AM
ok, my bad, i think my yui-ext is outdated :oops: cause once i direct links yui-ext from yui-ext.com, it works... however the masking overlay is not working..

Animal
29 Nov 2006, 3:39 AM
You need to include yui-ext.css

Animal
29 Nov 2006, 3:40 AM
That's instead of the other CSS files. Jack has concatenated them into one handy package.

wos
29 Nov 2006, 3:41 AM
omg, it working prefectly, thanks!!!!!

wos
29 Nov 2006, 3:47 AM
i did't know that was a update and i just grab the latest package :) anyway thanks for being such helpful to noob like me :P