PDA

View Full Version : Error : MultiSelect ComboBox in Ext 3.0_Plz help me



ducanh28487
23 Dec 2009, 12:42 AM
Hi everyone, i'm a newbie, i'm having a trouble with MultiSelect ComboBox of TonyLandis http://tonylandis.com/code/ext-multiselect-combobox-extension/ . When i used it in ext 2.3, it's quite good but when i changed my ext to version 3.0, the error is throwned "p is undefined", this error is in line in MultiSelect.js file: this.menu.show(this.el, "bottom");. Could somebody help me to fix this bug, plz, i have waste many time for it. (T_T)

Condor
23 Dec 2009, 4:46 AM
Ext 2.x extensions are usually not compatible with Ext 3.x and require an upgrade.

You should contact the author and see if an Ext 3.x version of the component is available.

If it's not, you could the try replacing your component with a LOVCombobox (http://www.extjs.com/forum/showthread.php?t=32692).