PDA

View Full Version : Update to 3.1.0



bauchinj
10 Feb 2010, 12:48 AM
Hello - since I have updated ExtJS from 3.0 to 3.1.0 following vtype don't work:


Ext.apply(Ext.form.VTypes, {
username : function(val, field) {
for(var i=0; i < val.length; i++){
var char = val.charAt(i);
var ascii = char.charCodeAt(0);
if((ascii == 45) || (ascii == 95) || (ascii > 47 && ascii < 58) || (ascii > 64 && ascii < 91) || (ascii > 96 && ascii < 123)){
}
else{
return false;
}
}
},
usernameText : 'invalid username!'
});

Before I have updated it, it works fine...
don't find something in the update protokoll