View Full Version : formPanel.submit() not submitting????

10 Feb 2010, 12:44 PM
This is a problem that just started happening to me. The code for a file upload form to a apache commons fileUpload servlet was working just fine, and as far as I can tell hasn't changed.

Basically the action is set with the correct method and multi-part settings and when the button is pressed I can debug the execution of the onClick and see that the formPanel action URL is correct (copying and pasting to a browser produces the expected 405, GET not handled response). I can even trace execution down into the GXT/GWT javascript for the form submit, but the server never receives the post request. After this started happening I updated my GWT from 2.0.0 to 2.0.1 and GXT from 2.1.0 to 2.1.1 with no difference. I've tried both in Firefox and Safari. I've checked in FireBug to make sure the action is really set on the form.

Any suggestions on what I should be looking for in the Eclipse debugger or in Jetty? I'm at my wit's end at the moment. I've also tried with just deploying the compiled war to a standalone Jetty server with the same results.

10 Feb 2010, 1:10 PM

Well, I guess doing a couple of recompiles and restarts did it???? I don't know. I don't get it, but it appears to be working again? I hate these sorts of things. I really don't know what happened here.