PDA

View Full Version : 3.1.1 ext-all.js error



teddyjas
4 Mar 2010, 6:43 PM
Hi guys..
not js related problem (well somehow it is).

My webserver is configured in such a way that javascripts files can be parsed by PHP, this is to enable dynamic javascript creations using php.

Now I just upgraded my extjs to 3.1.1 and found that I got php parsed error becos the ext-all.js mite probably contains javasripts codes that is parsed by php and throw error as php interpretes it as error.

However if I use the ext-all-debug.js its working fine, so I guess there's php codes in the condensed version of the ext-all.js

The previous ext-all.js version 3.0.1 has no issue of this.

So I wondering if the condensed ext-all.js also can be compatible with the PHP like the previous version :D ?

tobiu
5 Mar 2010, 12:59 AM
hi teddyjas,

take a look at:
http://www.extjs.com/forum/showthread.php?t=85381

its fixed in the 3.2 branch and you can easily replace <? and ?> with <'+'? so long.


kind regards,
tobiu

teddyjas
5 Mar 2010, 1:03 AM
thanks dude... yup thats wat was I got the error from, was hoping if I can download the 'fixed' version :) as 3.2 i not able to download :)