Updating ruby to 1.9.3 using rvm worked for me. Didn't work with 1.8.7... Thanks schmeltex & renku!