Downgrading to Ruby 1.9.3 worked for me as well !!!

Looks like a compatibility issue sencha cmd 3.1.0.256 --> Ruby Ruby 2.0.0-p0 ?!

Before this i tried installing 32-bit JRE, 64-bit JRE and...