Thank you for reporting this bug. We will make it our priority to review this report.
[CLOSED] xds-126.96.36.199: Omission of the option "jsClass" in the Container widget?
there is no possibility to change the name of a Container widget in the Component Config grid.
Is it intentioned?
ps: Screenshot at: http://misc.42loops.com/1mZXet
Hope that helps.
the "Promote to Class" feature did it!