Results 1 to 5 of 5

Thread: Youtube appears as "objects" stuck to screen

  1. #1
    Ext User
    Join Date
    Sep 2010
    Posts
    7
    Vote Rating
    0
      0  

    Default Youtube appears as "objects" stuck to screen

    Hi everyone, I've come across a weird experience with youtube embed. When you have a Ext.Panel with its html property containing embedded codes from youtube, the preview box appears but -- it DOESN'T scroll with the screen (if you have a long html doc) and seems "stuck" at screen positioning no matter what. This is most notable when there's multiple items of such.

    I've tried applying css position (fixed, absolute etc..) attributes to the div container it hosts but no avail. Any help anyone? Thank you!

  2. #2
    Sencha Premium User evant's Avatar
    Join Date
    Apr 2007
    Location
    Sydney, Australia
    Posts
    19,215
    Vote Rating
    1008
      0  

    Default

    Are you embedding flash objects? Because that's not going to work on iPhone/iPad anyway.
    Twitter - @evantrimboli
    Former Sencha framework engineer, available for consulting.
    As of 2017-09-22 I am not employed by Sencha, all subsequent posts are my own and do not represent Sencha in any way.

  3. #3
    Ext User
    Join Date
    Sep 2010
    Posts
    7
    Vote Rating
    0
      0  

    Default

    I copied the embed code directly from Youtube's embed feature; though it has Flash related variables it actually loads and can play videos directly. Probably HTML5 code is passed when the user-agent is detected as iPhone.

    You see I was trying to develop a page that is similar to the Timeline part in the "Guide" example -- rather than list of tweets but a list of youtube video objects than can be clicked. It works initially, but after viewing the video and returning back to the screen, the object gets "stuck", like a topmost window blocking other content...

  4. #4
    Sencha User
    Join Date
    Aug 2010
    Location
    https://github.com/RandyMcMillan
    Posts
    27
    Vote Rating
    0
      0  

    Default The problem isn't in sencha...

    The problem is in how UIWebView handles YouTube objects.

  5. #5
    Ext User
    Join Date
    Mar 2010
    Posts
    3
    Vote Rating
    0
      0  

    Default

    I'm seeing the same thing too. wondering if anyone has a workaround. It also "sticks" on the screen when you animate a new card in and out with a youtube embed on the screen.

Similar Threads

  1. Replies: 17
    Last Post: 18 Dec 2009, 11:04 AM
  2. Replies: 4
    Last Post: 3 Jul 2009, 10:19 PM
  3. Tabpanel with "many" items, right and left scroller do not appears
    By Etienne Jouvin in forum Ext 2.x: Help & Discussion
    Replies: 4
    Last Post: 22 Oct 2008, 9:42 AM
  4. New CheckboxGroup appears with "x-hidden" class.
    By bshagnasty in forum Ext 2.x: Help & Discussion
    Replies: 3
    Last Post: 6 Oct 2008, 8:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •