Results 1 to 6 of 6

Thread: Problem with EditorGridPanel store's remoteSort = true after 10 or so sorts ...

  1. #1
    Sencha User
    Join Date
    Nov 2008
    Posts
    163

    Default Problem with EditorGridPanel store's remoteSort = true after 10 or so sorts ...

    Is anyone else having an issue with sorting a GridPanel after sorting 10-15 sorts?

    I have an EditorGridPanel using a JsonStore configured to do a remoteSort. All works as expected after 10-15 sorts by clicking on the various columns in the grid ... BUT at some point requests to the server are just not sent. Instead, things churn away in the browser until finally I see a "401 Aborted" message in the console.

    Can I actually be making too many requests ... or too quickly? I don't get it.

    Thanks -wg

    *** UPDATE ***

    The problem seems to be related more to how long the grid was first rendered. After about 30 seconds none of the requests as a result of sorting (or filtering for that matter) go to the server.
    Last edited by wgpubs; 3 Nov 2010 at 1:08 AM. Reason: Problem seems time sensitive

  2. #2
    Sencha User Condor's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    24,246

    Default

    Debug your requests with the Firebug Net tab or Fiddler2.

    Does the sort request get sent?
    Does the server respond correctly?
    When the next sort request is sent, are there any requests still open?

    (sounds like a server problem)

  3. #3
    Sencha User
    Join Date
    Nov 2008
    Posts
    163

    Default

    >> Does the sort request get sent?
    The sort request get sent for awhile but for some reason, after a period of time, they stop getting sent

    >> Does the server respond correctly?
    Yes. As I said, requests are processed correctly for a number of sorts

    >> When the next sort request is sent, are there any requests still open?
    No. The grid is locked down until sorting finishes.


    When the problem occurs, Firebug gives me the impression that it is waiting on the GET request to return ... BUT I've verified via setting breakpoint in my ASP.NET MVC app that the request isn't even being processed. Only *after* the request times out (which I think defaults to 30 seconds) does my breakpoint in my server-side code actually hit! So, as weird as it sounds, it looks like the request is only sent AFTER it times out on the client side.

  4. #4
    Sencha User
    Join Date
    Nov 2008
    Posts
    163

    Default

    Firebug is reporting the following:

    "Failed to load source for: http://localhost/sampleWeb/Locations?_dc=1288776722923&start=0&limit=50&sort=Unit&dir=ASC" along with a "401 Aborted"

    So I guess it is coming from the server ... but I don't get why.

  5. #5
    Sencha User
    Join Date
    Nov 2008
    Posts
    163

    Default

    The problem seems to be with using Windows Integrated authentication.

    Usually ExtJs properly handles 401 responses (challenges from the server) by simply re-requesting the resource. But for some reason (not sure if this is something with ExtJs, IIS7, Integrated Authentication or whatever) when I do remoteSorting .... I eventually get a 401 challenge *BUT* the resource is NOT re-requested.

    Anybody dealing with this? Solutions?

  6. #6
    Sencha User Condor's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    24,246

    Default

    Browsers don't automatically retry requests with 401 status!

    Some browsers (e.g. Firefox) even show a login dialog (even though it was an non-interactive XmlHttpRequest).

Similar Threads

  1. GroupingStore with remoteSort: true does not work
    By fabiojpoli in forum Ext 3.x: Help & Discussion
    Replies: 2
    Last Post: 5 Oct 2010, 1:51 PM
  2. remoteSort=true on JsonStore don't work
    By soffio99 in forum Ext 3.x: Help & Discussion
    Replies: 3
    Last Post: 19 Apr 2010, 11:28 AM
  3. Replies: 10
    Last Post: 10 Feb 2009, 2:37 PM
  4. Ext.data.Store, remoteSort:true and method:'get'
    By pbarnes in forum Ext 2.x: Help & Discussion
    Replies: 3
    Last Post: 18 Jun 2008, 7:20 AM
  5. Problem getting remoteSort: true action with column sort
    By CutterBl in forum Ext 2.x: Help & Discussion
    Replies: 4
    Last Post: 31 Jan 2008, 1:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •