I'm all open for cleaning up the API.
Though, I'm not happy with the recent API changes regarding the form field classes in Sencha Touch 1.0 RC1.
Having a class NumberField makes more sense to me, than having a class named only Number.
Ext.form.DatePickerField renamed to Ext.form.DatePicker
Ext.form.EmailField renamed to Ext.form.Email
Ext.form.HiddenField renamed to Ext.form.Hidden
Ext.form.NumberField renamed to Ext.form.Number
Ext.form.PasswordField renamed to Ext.form.Password
Ext.form.SearchField renamed to Ext.form.Search
Ext.form.SpinnerField renamed to Ext.form.Spinner
Ext.form.TextField renamed to Ext.form.Text
Ext.form.UrlField renamed to Ext.form.Url
You may *guess* that it's a field because of the form namespace. But why guessing when it can be explicit.
Well, that are just my 2 cents.
Woud like to know what others think, therefore I added a nice poll.