Results 1 to 5 of 5

Thread: Tree elbow images

  1. #1
    Sencha User
    Join Date
    Feb 2010
    Posts
    11
    Vote Rating
    -1
      0  

    Default Tree elbow images

    Hi everybody,

    ss.png

    I have a tree panel and lots of tree nodes in it. Everything is working fine expect there is a little problem. In the attached screenshot, my tree nodes do not have elbow images and loading gif is just behind the node icon. (in this screenshot loading gif is behind the Menu node's icon) What is the problem. How can I fix this little glitch?

    PS: Here is some elbow images. elbow-minus.gifelbow.gif

    Thanks in advice.

    Fatih

  2. #2
    Sencha User arthurakay's Avatar
    Join Date
    Sep 2008
    Location
    Antioch, IL
    Posts
    1,516
    Vote Rating
    77
      0  

    Default

    Do you have "lines" set to false on your TreePanel config? It should default to true, which displays the lines.

    If that isn't the issue, what does FireBug tell you? Do you see any problems with your CSS? (Turn on CSS errors). Also, is this issue limited to a particular browser?

    If none of that solves the problem... are you overriding anything relating to TreePanel? Post some code.

  3. #3
    Sencha User
    Join Date
    Feb 2010
    Posts
    11
    Vote Rating
    -1
      0  

    Default

    Yeah, what a mistake. I have a base tree and every tree is extended from base tree. And in base tree there was a property
    lines: false
    I removed that and it's worked. But node loading gif is still behind the node icon. Any solution?

    Thanks arthurakay

  4. #4
    Sencha Premium User mankz's Avatar
    Join Date
    Nov 2007
    Location
    Stockholm, Sweden
    Posts
    3,042
    Vote Rating
    182
      0  

    Default

    How does your CSS class look that sets the icon?

  5. #5
    Sencha User
    Join Date
    Oct 2012
    Posts
    1
    Vote Rating
    0
      0  

    Default

    Hi mankz, I am having the same problem with version 3.0 and I did set "lines" to false but still having the problem ... Do you have any other idea what could it be ? Thank you very much

Similar Threads

  1. Howto Custom: x-tree-elbow-plus / minus
    By insnet in forum Ext 2.x: Help & Discussion
    Replies: 14
    Last Post: 7 Nov 2014, 4:48 AM
  2. Right-To-Left images/Icons for Ext JS Tree Panel
    By elnove in forum Community Discussion
    Replies: 3
    Last Post: 19 Sep 2013, 1:13 AM
  3. Tree (/deploy/ext-1.0-alpha3/resources/images/default/s.gif)
    By castillojefferson in forum Ext 2.x: Help & Discussion
    Replies: 7
    Last Post: 15 Apr 2009, 3:51 PM
  4. get-images.php to get-images.cfm
    By Mrblue in forum Ext 2.x: Help & Discussion
    Replies: 4
    Last Post: 23 Apr 2008, 1:09 AM
  5. Tree images disappear after a while
    By maya in forum Ext 1.x: Help & Discussion
    Replies: 13
    Last Post: 17 May 2007, 1:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •