Results 1 to 3 of 3

Thread: "columns" menu is displayed all the time

  1. #1

    Default "columns" menu is displayed all the time

    Dear all,

    I wanted to disable the standard "columns" menu (see picture).

    extjscolumns.png

    Even when I have set all columns of the grid to "hideable: false" the menu is displayed (containing no entry).

    Is this a bug or did I missed the feature to disable the menu at all?

    Thank you for your help!

    Best regards

    Matthias

    ps.: I found a fix on this website: http://codeology.lloydkinsella.net/?...=1#comment-492

  2. #2
    Sencha User kneth's Avatar
    Join Date
    Apr 2009
    Posts
    34

    Default

    Have you tried setting the "enableColumnHide" property of grid to false?

  3. #3

    Default Great!

    EnableColumnHide:false works perfectly!

    Thank you for your help!

Similar Threads

  1. When is the "right time" to hide some of menu items?
    By atchijov in forum Ext 3.x: Help & Discussion
    Replies: 0
    Last Post: 26 Aug 2009, 2:05 PM
  2. Replies: 1
    Last Post: 31 May 2009, 7:09 PM
  3. Replies: 1
    Last Post: 17 Apr 2009, 5:19 AM
  4. Replies: 4
    Last Post: 18 Feb 2009, 8:42 AM
  5. Disable Grid column context , menu Item "Columns"
    By mmax in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 22 Nov 2007, 6:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •