Results 1 to 3 of 3

Thread: Grid not working after update to 2.2.1 from 2.1.1

  1. #1
    Sencha User
    Join Date
    Oct 2010
    Posts
    6
    Vote Rating
    0
      0  

    Question Grid not working after update to 2.2.1 from 2.1.1

    Hi all

    I'm at my wits end with this problem. We have recently updated to GXT 2.2.1 from 2.1.1 which resulted in a problem with drag and drop between grids. No changes has been made in the code after upgrading, and the code was made after the DND Example in the Explorer Demo.

    The problem can be described shortly: Nothing is displayed in the grid. No headers - no data. But when I look at the source of the HTML generated it looks as it is creating all the rows but does not fill them out with cells. I have 87 of these
    Code:
    <div class="x-grid3-row  x-unselectable-single" style="width: 0px;" id="x-auto-555_x-auto-564">
      <table class="x-grid3-row-table" role="presentation" style="width: 0px;" border="0" cellpadding="0" cellspacing="0">
        <tbody role="presentation">
          <tr role="presentation"></tr>
        </tbody>
      </table>
    </div>
    I have set my own renderer, but they are not called when rendering.

    Any idea as to where I should look. Have been searching and debugging for 2 days now.

    Regards,
    Svend

  2. #2
    Sencha Premium Member
    Join Date
    Sep 2007
    Posts
    13,976
    Vote Rating
    131
      0  

    Default

    Are you sure your ColumnModel containes something?

  3. #3
    Sencha User
    Join Date
    Oct 2010
    Posts
    6
    Vote Rating
    0
      0  

    Default It's alive... again..

    Hi Sven

    Thank you for your swift reply. It appears that there are changes to the constructor in ColumnModel. It creates a new ArrayList of the ColumnConfigs but in 2.1.1 it just uses the ArrayList passed in the constructor. No indication of that was in the Release Notes. But with your hint (which was spot on) it works again.

    Thanks,
    Svend

Similar Threads

  1. Update Progres not working
    By krisp.net in forum Ext 3.x: Help & Discussion
    Replies: 0
    Last Post: 11 Mar 2010, 1:03 PM
  2. BubbleEvents not Working after update from 3.1.0 to 3.1.1
    By pwfraley in forum Ext 3.x: Help & Discussion
    Replies: 0
    Last Post: 12 Feb 2010, 6:42 AM
  3. Store update not working
    By fzammetti in forum Ext 2.x: Help & Discussion
    Replies: 0
    Last Post: 17 Nov 2008, 10:32 AM
  4. update not working on IE6 :(
    By herranzr in forum Ext 1.x: Help & Discussion
    Replies: 18
    Last Post: 2 Jun 2008, 11:57 AM
  5. DeferredRender on TabPanel not working after update
    By bolanki in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 6 Nov 2007, 11:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •