Results 1 to 3 of 3

Thread: Backward compatibility ExtJS 4

  1. #1
    Sencha Premium Member
    Join Date
    Feb 2009
    Location
    Amsterdam, The Netherlands
    Posts
    245

    Default Backward compatibility ExtJS 4

    Hi to all,
    I'm about to start a new product and would like to eventually include ExtJS 4 in it. How backward compatible would it be with ExtJS 3?

    Cheers!

  2. #2
    Sencha User jay@moduscreate.com's Avatar
    Join Date
    Mar 2007
    Location
    DC Area =)
    Posts
    16,364

    Default

    I've read it will be a "Mechanical upgrade", meaning there is work involved on your part.

    Also, if you include any third party plugins, those will need to be ported over. Lastly, if your code does not follow the best practices, you will endure pain. Obviously these last two points have nothing to do w/ Sencha Inc directly.

  3. #3
    Sencha User edspencer's Avatar
    Join Date
    Jan 2009
    Location
    Palo Alto, California
    Posts
    1,939

    Default

    We're creating a legacy file that you can include to help upgrade your app. Basically the legacy file is a diff between 3.x's API and 4.x's API with shim methods where appropriate and warning messages thrown where not. You will have to make changes to your app, but the legacy file and upgrade guide should make that relatively straightforward.
    Ext JS Senior Software Architect
    Personal Blog: http://edspencer.net
    Twitter: http://twitter.com/edspencer
    Github: http://github.com/edspencer

Similar Threads

  1. 0.99 and backward compatibility / professional softaware
    By axxerion in forum Sencha Touch 1.x: Discussion
    Replies: 3
    Last Post: 8 Nov 2010, 9:56 AM
  2. Backward compatibility
    By run2sri in forum Sencha Touch 1.x: Discussion
    Replies: 1
    Last Post: 6 Jul 2010, 12:55 PM
  3. EXT GWT backward compatibility
    By Priyams in forum Community Discussion
    Replies: 3
    Last Post: 15 Dec 2009, 3:18 PM
  4. [CLOSED] ComboBox backward compatibility error
    By zdarsky in forum Ext GWT: Bugs (2.x)
    Replies: 1
    Last Post: 30 Oct 2009, 4:07 AM
  5. Backward compatibility
    By PT LUI in forum Ext 2.x: Help & Discussion
    Replies: 7
    Last Post: 12 Sep 2007, 10:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •