Results 1 to 3 of 3

Thread: Internal Compile Error! Found interface com.google.gwt.core.ext.typeinfo.JClassType

  1. #1
    Sencha User naveedanjum's Avatar
    Join Date
    Feb 2010
    Location
    Islamabad, Pakistan
    Posts
    21

    Question Internal Compile Error! Found interface com.google.gwt.core.ext.typeinfo.JClassType

    Hello There,

    I am newbie to Ext GWT. As per official tutorial to
    http://www.sencha.com/blog/setting-u...ct-in-eclipse/

    I have setup the hello world project. But I am encountering the Found Interface required abstract class error. Found interface com.google.gwt.core.ext.typeinfo.JClassType

    My Development Environment is
    1. Eclipse J2EE 3.6 Version: Helios Release
    2. GWT SDK 2.2. (As per update by Google)
    3. Ext GWT 2.2.1 (Latest)

    PHP Code:
    package com.hello.gxt.client;

    import com.extjs.gxt.ui.client.widget.MessageBox;
    import com.google.gwt.core.client.EntryPoint;

    /**
     * Entry point classes define <code>onModuleLoad()</code>.
     */
    public class HelloGXT implements EntryPoint{
        @
    Override
        
    public void onModuleLoad() {
            
    MessageBox.info("Message""Hello World!!"null);
        }

    Why we are getting this error, is there any way to fix it up.
    Farrukh Naveed Anjum
    Team Lead (Software Engineer)

  2. #2
    Sencha Premium User
    Join Date
    Nov 2008
    Location
    Vienna - Austria
    Posts
    888

    Default

    The forum search actually works!

    Look what I found by looking for: "com.google.gwt.core.ext.typeinfo.JClassType"

    http://www.sencha.com/forum/showthre...nfo.JClassType

    http://www.sencha.com/forum/showthre...nfo.JClassType

    http://www.sencha.com/forum/showthre...nfo.JClassType

    http://www.sencha.com/forum/showthre...nfo.JClassType

    http://www.sencha.com/forum/showthre...nfo.JClassType


    I'm pretty confident you will find the reason in some of these threads...

  3. #3
    Sencha User naveedanjum's Avatar
    Join Date
    Feb 2010
    Location
    Islamabad, Pakistan
    Posts
    21

    Default

    Hi There!

    Thanks for replying i had done search on Fourm, but found the reason it is not compatible with GWT 2.2.0 I was hoping if some one had made a work around of it. But apparently there is no solution till this moment.

    For all others following is what I did to solve this problem (Eclipse Helios 3.6)

    1. Uninstall GWT SDK 2.2 from Installed Plugins
    2. Download GWT 2.0.4
    3. Go to Windows -> Preferences -> Google -> Web Toolkit
    4. Click on Add Button and Point to GWT 2.0.4 (Extracted Folder)
    5. Now compile your code it will work.
    6. Cheers.
    Farrukh Naveed Anjum
    Team Lead (Software Engineer)

Similar Threads

  1. Replies: 1
    Last Post: 8 Jul 2010, 4:57 PM
  2. Unexpected internal compiler error when compile
    By coodysk8er in forum Ext GWT: Help & Discussion (1.x)
    Replies: 9
    Last Post: 26 Jun 2009, 2:23 AM
  3. Replies: 1
    Last Post: 21 Apr 2009, 8:00 AM
  4. Replies: 1
    Last Post: 21 Apr 2009, 8:00 AM
  5. Service Interface Compile Error on upgrade to B4
    By larvelljones in forum Ext GWT: Help & Discussion (1.x)
    Replies: 0
    Last Post: 6 Jun 2008, 11:36 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •