Page 1 of 7 123 ... LastLast
Results 1 to 10 of 64

Thread: [Beta3] API Doc Issues

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,449

    Default [Beta3] API Doc Issues

    Since releases are happening pretty much every week there are some issues that may be with an earlier release that may not be there in Beta3. Please the other thread is just going to get longer and longer.

    This thread is for API Documentation issues with the Ext JS 4 Beta 3 release only.
    Mitchell Simoens @LikelyMitch
    Modus Create, Senior Fullstack Engineer
    ________________
    Modus Create is based on the model of an open source team. We’re a remote, global team of experts in our field. To find out more about the work we do, head over to our website.

    Check out my GitHub:
    https://github.com/mitchellsimoens

  2. #2
    Ext JS Premium Member
    Join Date
    May 2010
    Posts
    8

    Default

    The docs are great and getting better all the time, but...

    If you go to one of the guides, e.g.
    http://dev.sencha.com/deploy/ext-4.0...uide/grid.html

    And then try to navigate to, for example, the documentation for a class you get a 404 because the link is now relative to the guide:
    http://dev.sencha.com/deploy/ext-4.0-beta3/docs/guide/api/Ext.data.Store.html

    Cheers!

  3. #3
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,449

    Default

    Quote Originally Posted by keltnerj View Post
    The docs are great and getting better all the time, but...

    If you go to one of the guides, e.g.
    http://dev.sencha.com/deploy/ext-4.0...uide/grid.html

    And then try to navigate to, for example, the documentation for a class you get a 404 because the link is now relative to the guide:
    http://dev.sencha.com/deploy/ext-4.0-beta3/docs/guide/api/Ext.data.Store.html

    Cheers!
    This has been a bug for last couple releases at least. It's the same if you click on an item when you hover over config at the top of a class API and then try to go to another class the URL is messed up. I have entered this into our bug tracker.
    Mitchell Simoens @LikelyMitch
    Modus Create, Senior Fullstack Engineer
    ________________
    Modus Create is based on the model of an open source team. We’re a remote, global team of experts in our field. To find out more about the work we do, head over to our website.

    Check out my GitHub:
    https://github.com/mitchellsimoens

  4. #4
    Sencha User ykey's Avatar
    Join Date
    Mar 2010
    Location
    USA
    Posts
    245

    Default

    Please make the Sencha logo in the API a link back to the index so we can return to the Guides listing without manually changing the url.

  5. #5
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,449

    Default

    Quote Originally Posted by ykey View Post
    Please make the Sencha logo in the API a link back to the index so we can return to the Guides listing without manually changing the url.
    Duly noted and reported! I thought that when I first started playing with the guides
    Mitchell Simoens @LikelyMitch
    Modus Create, Senior Fullstack Engineer
    ________________
    Modus Create is based on the model of an open source team. We’re a remote, global team of experts in our field. To find out more about the work we do, head over to our website.

    Check out my GitHub:
    https://github.com/mitchellsimoens

  6. #6
    Ext JS Premium Member
    Join Date
    Apr 2010
    Posts
    56

    Default

    Ext.app.Application.autoCreateViewport is reported as a {String}, when it is in fact {Boolean}:

    http://dev.sencha.com/deploy/ext-4.0...plication.html

  7. #7
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,449

    Default

    Quote Originally Posted by korax View Post
    Ext.app.Application.autoCreateViewport is reported as a {String}, when it is in fact {Boolean}:

    http://dev.sencha.com/deploy/ext-4.0...plication.html
    Thank you, reported!
    Mitchell Simoens @LikelyMitch
    Modus Create, Senior Fullstack Engineer
    ________________
    Modus Create is based on the model of an open source team. We’re a remote, global team of experts in our field. To find out more about the work we do, head over to our website.

    Check out my GitHub:
    https://github.com/mitchellsimoens

  8. #8
    Sencha User tobiu's Avatar
    Join Date
    May 2007
    Location
    Munich (Germany)
    Posts
    2,751

    Default

    the forums -> api docs are still linking to b2.


    best regards
    tobiu
    Best regards
    Tobias Uhlig

  9. #9
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,449

    Default

    Quote Originally Posted by tobiu View Post
    the forums -> api docs are still linking to b2.
    Escalated!
    Mitchell Simoens @LikelyMitch
    Modus Create, Senior Fullstack Engineer
    ________________
    Modus Create is based on the model of an open source team. We’re a remote, global team of experts in our field. To find out more about the work we do, head over to our website.

    Check out my GitHub:
    https://github.com/mitchellsimoens

  10. #10
    Sencha User tobiu's Avatar
    Join Date
    May 2007
    Location
    Munich (Germany)
    Posts
    2,751

    Default

    http://dev.sencha.com/deploy/ext-4.0...plication.html

    Not Found

    The requested URL /deploy/ext-4.0-beta3/docs/guide/api/Ext.app.Application.html was not found on this server.

    Apache/2.2.14 (Ubuntu) Server at dev.sencha.com Port 80
    Best regards
    Tobias Uhlig

Page 1 of 7 123 ... LastLast

Similar Threads

  1. [Ver. 1.0-beta3] Ext.ux.FileTreePanel
    By jsakalos in forum Ext 1.x: User Extensions and Plugins
    Replies: 275
    Last Post: 2 Apr 2010, 4:34 PM
  2. beta3 and performance
    By cdgokey in forum Community Discussion
    Replies: 10
    Last Post: 19 May 2008, 5:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •