Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: GWT 2.3.0 support

  1. #1
    Sencha User
    Join Date
    Oct 2008
    Posts
    25

    Default GWT 2.3.0 support

    Does anybody know when the GWT v2.3.0 compatible GXT version will be released?

    Best,
    -- Thomas Amsler
    UC Davis

  2. #2
    Sencha Premium Member
    Join Date
    Sep 2007
    Posts
    13,976

    Default

    It will be released soon. There is no date yet. There is only a simple change required, which is even optional

  3. #3
    Ext GWT Premium Member
    Join Date
    Oct 2009
    Posts
    57

    Default

    Hi Sven
    Can you please provide what the optional change is so we can start doing some preliminary testing (as there is no specific date when the GXT version wil come out)?

  4. #4
    Sencha Premium Member
    Join Date
    Sep 2007
    Posts
    13,976

    Default

    This change is not required and GXT 2.2.3 is compatible with GWT 2.3.0 without this change

  5. #5
    Ext GWT Premium Member
    Join Date
    Oct 2009
    Posts
    57

    Default

    Thanks Sven! That is great. So if am I interpretign this correctly to mean that:
    - there is no need to wait for and no plans to release a GXT version past 2.2.3 just to be gwt2.3 compatible and
    - I can ignore the various other comments in other threads also that indicate Sencha is working on a new release for 2.3 e.g.
    http://www.sencha.com/forum/showthre...binding-errors

  6. #6
    Sencha Premium Member
    Join Date
    Sep 2007
    Posts
    13,976

    Default

    The thread you linked explains in detail why GXT 2.2.3 supports GWT 2.3.0 and why the change is optional.

    GWT 2.3.0 support is not linked to IE9 support. For that a new release is required.

  7. #7

    Default Window will not open using gwt 2.3.0 + gxt 2.2.4 + ie 8

    Hi

    I am using gwt 2.3.0 + gxt 2.2.4 and ie 8 ... observed ... Modal Window will not open ...

    Works fine in mozilla ...

    Cheers
    Ashley

  8. #8
    Sencha User
    Join Date
    May 2009
    Posts
    12

    Default Compatibility Matrix

    Is there a GWT/GXT compatibility matrix?

    I am using GXT 2.2.0 with GWT 2.3.0 and am having compilation problems:

    Code:
    [INFO] java.lang.IncompatibleClassChangeError: Found interface com.google.gwt.core.ext.typeinfo.JClassType, but class was expected
    [INFO]     at com.extjs.gxt.ui.rebind.core.TemplatesGenerator$SourceGenerator.validateType(TemplatesGenerator.java:142)
    [INFO]     at com.extjs.gxt.ui.rebind.core.TemplatesGenerator$SourceGenerator.generate(TemplatesGenerator.java:97)
    [INFO]     at com.extjs.gxt.ui.rebind.core.TemplatesGenerator.generate(TemplatesGenerator.java:56)
    [INFO]     at com.google.gwt.core.ext.GeneratorExtWrapper.generate(GeneratorExtWrapper.java:48)
    [INFO]     at com.google.gwt.core.ext.GeneratorExtWrapper.generateIncrementally(GeneratorExtWrapper.java:60)

  9. #9
    Sencha Premium Member
    Join Date
    Sep 2007
    Posts
    13,976

    Default

    You will need to use GXT 2.2.3 and the build for GWT 2.2.0 or make a new build against GWT 2.2 with any GXT version.

    There was a braking change in GWT 2.2.

    The build for GWT 2.2 also works for GWT 2.3.

    However when upgrading GXT i would suggest do directly go to GXT 2.2.4. Why did you only update GWT and not also GXT?

  10. #10
    Sencha User
    Join Date
    May 2009
    Posts
    12

    Default

    I was using the version of GXT I had downloaded earlier in the year - maybe from last year? I'll update it.

    Thanks for the assist.

    Greg

Page 1 of 2 12 LastLast

Similar Threads

  1. Ext 4.0 (offline support, local database support)
    By tfrugia in forum Community Discussion
    Replies: 1
    Last Post: 27 Apr 2010, 8:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •