Results 1 to 4 of 4

Thread: Ext Designer returning 'not well formed' error on exported pages

  1. #1
    Sencha User
    Join Date
    Aug 2011
    Posts
    2
    Vote Rating
    0
      0  

    Default Ext Designer returning 'not well formed' error on exported pages

    I'm getting an error in firefox when trying to load a project I created from ext designer. Basicly I create a new file in ext designer, put one label in saying 'hello world' and then save and export the file. When I try to load up the file in firefox i get the error:

    Error: not well-formed
    Source File: file:///C:/app/view/MyLabel.js?_dc=1314187186312
    Line: 1, Column: 1
    Source Code:
    /*

    When I look at the file creating the error, it contains this:


    /*
    * File: app/view/MyLabel.js * Date: Wed Aug 24 2011 12:57:30 GMT+0100 (GMT Daylight Time)
    *
    * This file was generated by Ext Designer version 1.2.0.
    * http://www.sencha.com/products/designer/
    *
    * This file will be generated the first time you export.
    *
    * You should implement event handling and custom methods in this
    * class.
    */

    Ext.define('MyApp.view.MyLabel', {
    extend: 'MyApp.view.ui.MyLabel',
    initComponent: function() {
    var me = this;
    me.callParent(arguments);
    }
    });

    I've checked that all the files are being loaded correctly (no 404 errors anywhere). Is there anything I'm doing wrong here?

    thanks for any help

  2. #2
    Sencha User
    Join Date
    Aug 2011
    Posts
    2
    Vote Rating
    0
      0  

    Default

    It looks as if this may be a similar error to this one:
    http://www.sencha.com/forum/showthre...-first-example

    as I'm also getting that error message after the 'not well-formed' message I described. Is there anyone that solved that problem? All I'm getting right now is those 2 error messages and a blank screen.

  3. #3
    Sencha Premium Member skirtle's Avatar
    Join Date
    Oct 2010
    Location
    UK
    Posts
    3,790
    Answers
    583
    Vote Rating
    391
      0  

    Default

    Try viewing the JS file in a hex/byte viewer. Maybe there are BOMs at the start of that first line that are screwing things up.

    Try it in other browsers. Diagnostically that can be very enlightening.

    Try putting charset="UTF-8" on the script tag.

    Have you tried serving this up using a webserver rather than just directly off the filesystem?

  4. #4
    Sencha User
    Join Date
    Nov 2007
    Posts
    1
    Vote Rating
    0
      0  

    Default Needs to run off a web server

    I had this problem. Running from a web server instead of running off the file system fixes it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •