Results 1 to 3 of 3

Thread: Webapp doesn't work only on iPhone HomeScreen

    Looks like we can't reproduce the issue or there's a problem in the test case provided.
  1. #1
    Sencha User siebmanb's Avatar
    Join Date
    Aug 2011
    Location
    Geneva (CH) - Grenoble (FR)
    Posts
    253

    Default Webapp doesn't work only on iPhone HomeScreen

    Hello everyone,

    I have a weird bug for you. My app works fine in Safari on a Mac and Safari on an iPhone. However, nothing works when you add the website to the "Home Screen" on the iPhone. It is driving me crazy : it is supposed to be exactly the same thing right ? Have you guys met this issue before ? I am using iOS5.

    From my investigations, it appears that the iPhone doesn't like to load a store on startup. Things work better if you load it afterwards, on a show event for example.

    Is there a way to debug a web app on the "Home Screen" of an iPhone ?


    Thank you all

  2. #2
    Sencha User siebmanb's Avatar
    Join Date
    Aug 2011
    Location
    Geneva (CH) - Grenoble (FR)
    Posts
    253

    Default

    Looks like I'm not the only one after all :

    http://www.sencha.com/forum/showthre...creen&p=669621

    Any idea on the reason ?

  3. #3
    Sencha User siebmanb's Avatar
    Join Date
    Aug 2011
    Location
    Geneva (CH) - Grenoble (FR)
    Posts
    253

    Default

    As expected, it was caused by a store being auto-loaded... You need to load the store when the view is rendered...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •