Results 1 to 3 of 3

Thread: Scroll is not shown after row expand in grid panel with row expander plugin

  1. #1
    Sencha Premium Member vadimv's Avatar
    Join Date
    Sep 2010
    Location
    Cluj, Romania
    Posts
    687
    Answers
    23
    Vote Rating
    50
      0  

    Default Unanswered: Scroll is not shown after row expand in grid panel with row expander plugin

    Hi
    Scroll is not shown after row expand in grid panel with row expander plugin, only in the case when the grid panel is shown without scroll bar, thus the high of the all records is less than panel's heigh.
    Is there a solution to solve this problem ! ?. tested on 4.0.7 + chrome.

  2. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,326
    Answers
    3884
    Vote Rating
    1297
      0  

    Default

    Have you tested this against 4.1-PR1? Scrolling went through a major overhaul and now uses the browser's native scrolling instead of our virtual one.
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it!

    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  3. #3
    Sencha Premium Member vadimv's Avatar
    Join Date
    Sep 2010
    Location
    Cluj, Romania
    Posts
    687
    Answers
    23
    Vote Rating
    50
      0  

    Default

    no haven't tested, 'cause the application is very close to the release, and will be released on 4.0.7. v4.1 is not stable yet.

    But I have found a solution, don't know if is a best one but works: my layout is card, and one of the cards is the grid panel, and fit's the card, then I configured it's viewConfig with autoscroll: true, didn't worked, this was the first try and thought should work. Then came the thoughts with the layout, if it fits the card, and the card is in center of the border layout, why I should set the height !!!!!?. But tried, and added maxHeight to the viewConfig and worked. So the solution is:
    Code:
       viewConfig: {
            autoScroll: true,
            maxHeight: Wizard.settings.height
        },
    it's a right one ?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •