I'm trying to build with adhoc certs so I can send my app around to clients and testers and I keep getting "Invalid IPA: missing embedded provisioning profile. Are you sure this is an ad hoc?".

The profile is adhoc and I can successfully run the build on my device, but inspecting the .app bundle it doesn't look like the embedded.mobileprovisioning profile exists. I'm able to partially work around this problem by copying my mobile provisioning profile used for signing into .app/embedded.mobileprovisioning. So far I've been able to upload to testflightapp and install on my own machine, though I'm not yet sure if my testers have been able to install. If this fails my next attempt will be to use xcrun (see http://nachbaur.com/blog/building-io...c-distribution) to generate the ipa instead of doing it manually:

xcrun -sdk iphoneos PackageApplication \
"path/to/build/MyApp.app" \
-o "output/path/to/MyApp.ipa" \
--sign "iPhone Distribution: My Company" \
--embed "path/to/something.mobileprovision"

It's also worth mentioning that the "versionString" has no effect, as my app still shows as v1.0 in testflightapp.

Also I've been completely unable to get a splash screen to work or remove the gloss from the icon. I've tried adding the following into my config.json and into my setup hoping it'd work:

"phoneStartupScreen": "Default.png",
"glossOnIcon": false

I've also placed a Default.png in every directory because somebody mentioned on the forums that the fix was to place it in the root, but this has no effect on sencha from what I've seen. I've even tried to drop it into the .app but obviously that invalidates the signature.

Any ideas on workarounds for any of these?