Results 1 to 9 of 9

Thread: How to even started with Sencha IO>???????

  1. #1
    Touch Premium Member
    Join Date
    Aug 2011
    Posts
    93
    Vote Rating
    1
      0  

    Default Answered: How to even started with Sencha IO>???????

    Hi,
    I have downloaded the Sencha.IO SDK. I included sencha-io-debug.js in my index.html like following:

    <body>
    <script src="lib/touch/sencha-touch-debug.js" type="text/javascript" charset="utf-8"></script>
    <script src="sencha-io.js" type="text/javascript" charset="utf-8"></script>


    <div id="sencha-app">
    <script type="text/javascript" src="app.js"></script>
    </div>
    </body>

    And I get this error:
    • [COLOR=red !important]1Uncaught TypeError: Cannot read property 'Batch' of undefined[/COLOR]
    [COLOR=red !important]
    [/COLOR]Apparently the error comes from the very first line: Ext.data.Batch.override({.....

    Anyway. I also cannot seem to get Ext.io to work.

    Any suggestion on how to get started will be greatly appreciated. My company needs to check out Sencha IO's messaging service.

    If it is not ready yet. I also hope to know. So I don't have to poke around the code anymore

    Di




  2. We recently shipped an update to SIO that works with ST2. You can download it here:

    http://download.sencha.io

    John

  3. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,326
    Answers
    3884
    Vote Rating
    1297
      0  

    Default

    You are using ST1 correct? Also, have you checked out the API doc for Sencha.io? When you login, there is a link in the right column
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it!

    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  4. #3
    Touch Premium Member
    Join Date
    Aug 2011
    Posts
    93
    Vote Rating
    1
      0  

    Default

    No I am using ST2 PR1 for this.
    Should I be using ST2 PR2?

    And I did check out the API. but it does not help me get rid off the error on the first line of code. Help needed.
    Thanks
    Di

  5. #4
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,326
    Answers
    3884
    Vote Rating
    1297
      0  

    Default

    I don't believe the Sencha.IO stuff is working in ST2 yet. ST2's API isn't frozen so some things are being held off because we are still in the PR stages.
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it!

    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  6. #5
    Touch Premium Member
    Join Date
    Aug 2011
    Posts
    93
    Vote Rating
    1
      0  

    Default

    I see. Thanks a lot. I ll using ST1 to play with IO then

  7. #6
    Touch Premium Member
    Join Date
    Aug 2011
    Posts
    93
    Vote Rating
    1
      0  

    Default

    Hi Mitchell,
    Thank you so much for your patience and quick response.
    I tried IO with ST1. But got this error: TypeError: Cannot read property 'WebStorage' of undefined

    What is confusing to me is that sencha-io.js is using ST2 syntax such as:
    Ext.define('Ext.io', {.....

    I still have no luck to get it started.
    I cannot even get hold of Ext.io. I tried Ext.io => undefined
    Basically it should not work because in ST1, Ext.define => undefined

  8. #7
    Sencha User
    Join Date
    Apr 2010
    Posts
    107
    Answers
    30
    Vote Rating
    -1
      0  

    Default

    Hello,

    The Sencha.io SDK only works with ST2 PR2. If you are still having problems then email me at merrells @ sencha.com and I'll help you get past this versions issue.

    John

  9. #8
    Sencha User
    Join Date
    Apr 2010
    Posts
    107
    Answers
    30
    Vote Rating
    -1
      0  

    Default

    We recently shipped an update to SIO that works with ST2. You can download it here:

    http://download.sencha.io

    John

  10. #9
    Touch Premium Member
    Join Date
    Aug 2011
    Posts
    93
    Vote Rating
    1
      0  

    Default

    Awesome! will check it out immediately

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •