I just uploaded a test app (more or less empty).
I created a user group "moo" with Login set to to "Before Download" and selected "Sencha ID (Developers) as "Authentication Service".
When I try to log-in all I get is a nginx timeout error.

Then I tried to switch the Authentication Service to "Sencha.io (Users)", and used the registration link from the login page that appears when I invoke the app's URL.
Result of registration is a redirection to "senchafy.com/hello" which only gives a 404.

What the heck?

However I saw in the "Developer console" that the group now has 1 registered user, so probably the registration worked.

Ok, so I try to login with the data I gave on registration ... and only get an endless redirection from my app to the login and back that only stops with a browser error ("Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.").

Sorry, but this feels like pre-alpha to me.
Is there anything I might have done fundamentally wrong to cause these issues?