Results 1 to 3 of 3

Thread: [B1] DOM NOT_FOUND_ERR after removing/adding from a card layout

  1. #1
    Sencha User dobie_'s Avatar
    Join Date
    Sep 2011
    Location
    Seattle, WA
    Posts
    47
    Vote Rating
    0
      0  

    Default [B1] DOM NOT_FOUND_ERR after removing/adding from a card layout

    I just upgraded to ST2 beta 1, and I'm getting an error in my app, but the cause is hard to trace:

    NOT_FOUND_ERR: DOM Exception 8

    I know this is vague, but hopefully someone else has a similar problem and we can narrow it down. Otherwise I'll try to put together a test case.

  2. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,553
    Vote Rating
    1272
      0  

    Default

    The cause for that when it has happened to me was trying to set a style or something when the component isn't rendered to the DOM anymore.
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

  3. #3
    Sencha User
    Join Date
    Jan 2012
    Posts
    74
    Vote Rating
    2
      0  

    Default

    I am dealing with something similar to this, however, if I keep clicking around it starts working again, sometimes generating ~40 errors simultaneously, I haven't had the best of luck reproducing it though, it seems that caching or something takes over, to have it working.

    I would, however, love it to not cough like this and just work smoothly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •