Results 1 to 3 of 3

Thread: Association function doesn't get created for hasMany model

  1. #1
    Ext JS Premium Member
    Join Date
    Jun 2011
    Location
    Ottawa, Ontario, Canada
    Posts
    123
    Vote Rating
    1
      0  

    Default Association function doesn't get created for hasMany model

    Hi

    It was working for 4.0.7, but doesnt work in 4.1.0 b2
    I wonder if I need to do some extra setting for that.

    I have a Document model that hasMany of Attribute model with name: attributes
    I deliver entire thing by one call and see that raw data contains 'attributes' node per each document but when I access 'record' I see that attributes() function does not exist.

    Thanks

  2. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,551
    Vote Rating
    1271
      0  

    Default

    In my usages, I have had no issues with associations migrating to 4.1.0
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

  3. #3
    Ext JS Premium Member
    Join Date
    Jun 2011
    Location
    Ottawa, Ontario, Canada
    Posts
    123
    Vote Rating
    1
      0  

    Default

    Probably that was for me due to dynamic loading of classes. When I added model classes to Ext.require it started to work fine

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •