Results 1 to 8 of 8

Thread: AjaxProxy actionMethods

  1. #1
    Sencha User
    Join Date
    Jan 2012
    Posts
    13

    Default AjaxProxy actionMethods

    Hello,

    do i have any possibility to change the actionMethods (eg to POST) within the Designer?

    Kind regards,
    Julian

  2. #2
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,488

    Default

    You could add a custom configuration on your ajax proxy by typing the following in the filter:
    actionMethods: {create: "POST", read: "GET", update: "POST", destroy: "POST"}

    and then clicking Add

    Docs for actionMethods
    http://docs.sencha.com/ext-js/4-0/#!...-actionMethods
    Aaron Conran
    @aconran

  3. #3
    Sencha User
    Join Date
    Jan 2012
    Posts
    13

    Default

    I knew actionMethods, but somehow missed the "Add" Button ..
    Thank you.

  4. #4
    Sencha User
    Join Date
    Sep 2008
    Posts
    118

    Default

    I am using EXT JS 4, with Ext Designer version 1.2.3 Build 50.

    I'm trying to add the configuration detailed in this thread within my Ajax Proxy's Component Config ( 'filter or quick value set...' area), but it's failing to add (and I don't see the add button mentioned here).

    Have I got a new enough version of designer? Where should I be explicitly looking?

    Thanks,
    Rob.

  5. #5
    Sencha User
    Join Date
    May 2012
    Posts
    4

    Default

    How to POST my "request" parameter ? Is my guessing right?

    Ext.define('MyApp.store.ERPXmlStore', {
    extend: 'Ext.data.Store',
    requires: [
    'MyApp.model.ERPModel'
    ],


    config: {
    autoLoad: true,
    model: 'MyApp.model.ERPModel',
    storeId: 'ERPXmlStore',
    proxy: {
    type: 'ajax',
    extraParams: '{ \n request:\n <request>\n <object type="ERP" name="Base" action="UserLogin"/>\n <data>\n <parameter name="Login"><![CDATA[demo]]></parameter>\n <parameter name="Password"><![CDATA[demo]]></parameter>\n </data>\n</request>\n}',
    filterParam: 'actionMethods: {create: "POST", read: "POST", update: "POST", destroy: "POST"}',
    url: '/sprj/ERPClient/XMLResponse.xml',
    reader: {
    type: 'xml',
    messageProperty: 'message',
    rootProperty: 'data',
    successProperty: '',
    record: 'dictionary'
    }
    }
    }
    });

  6. #6
    Sencha User
    Join Date
    Aug 2012
    Location
    Buenos Aires, Argentina
    Posts
    45

    Default Still seeing HTTP OPTIONS

    Hi, I am using a AjaxProxt where I defined
    actionMethods: {create: "POST", read: "POST", update: "POST", destroy: "POST"}

    and stil se OPTIONS instead of POST.

    My backend is Tomcat at 8080 and the front end where the Ext JS 4 app lives is on a JBoss AS on prt 9090, the conectivity is good and the YRL resolves to go the backend to 8080.

    The browser is a Firefox loaded with Firebug.

    How can I force the methods to use are those specified in actionMethods:?

    Thanks, Carlos

  7. #7
    Sencha Premium User couetbis's Avatar
    Join Date
    Jan 2008
    Location
    Nantes - France
    Posts
    108

    Default

    Hi,
    Have you resolve your problem ?
    I have the same...

  8. #8
    Sencha User
    Join Date
    Aug 2012
    Location
    Buenos Aires, Argentina
    Posts
    45

    Default no

    I abandoned that mission

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •