Success! Looks like we've fixed this one. According to our records the fix was applied for EXTJS-5455 in a recent build.
  1. #1
    Sencha - Support Team slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,120
    Vote Rating
    227
    slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of

      0  

    Default [B3] Placeholder not working?

    I'm having trouble getting placeholder to work. Is it something I'm doing wrong?

    Code:
    Ext.widget({
        xtype: 'viewport'
        , layout: 'border'
        , items: [{
            xtype: 'panel'
            , region: 'center'
        }, {
            xtype: 'panel'
            , region: 'west'
            , width: 200
            , collapsible: true
            , split: true
            , placeholder: Ext.create('Ext.toolbar.Toolbar', {
                vertical: true
                , items: [{
                    text: 'test'
                }]
            })
        }]
    });
    I've tried using Ext.widget, Ext.create, new, and just a config object with no luck.

  2. #2
    Sencha - Ext JS Dev Team dongryphon's Avatar
    Join Date
    Jul 2009
    Location
    Kansas
    Posts
    1,616
    Vote Rating
    212
    dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of

      0  

    Default

    The placeholder is used when a panel is collapsed inside a container using a border layout. What is it you are trying to achieve?
    Don Griffin
    Director of Engineering - Frameworks (Ext JS / Sencha Touch)

    Check the docs. Learn how to (properly) report a framework issue and a Sencha Cmd issue

    "Use the source, Luke!"

  3. #3
    Sencha Premium Member skirtle's Avatar
    Join Date
    Oct 2010
    Location
    UK
    Posts
    3,784
    Vote Rating
    379
    skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute

      0  

    Default

    This looks like a bug to me. Using 4.0.7 the following code shows a vertical toolbar when the panel is collapsed. In beta-3 it throws a JavaScript error when the collapse tool is clicked.

    Code:
    Ext.onReady(function() {
        Ext.widget('viewport', {
            layout: 'border',
            renderTo: Ext.getBody(),
            items: [
                {
                    region: 'center'
                }, {
                    collapsible: true,
                    region: 'west',
                    split: true,
                    width: 200,
                    placeholder: Ext.create('Ext.toolbar.Toolbar', {
                        xtype: 'toolbar',
                        vertical: true,
                        items: [{
                            text: 'test'
                        }]
                    })
                }
            ]
        });
    });

  4. #4
    Sencha - Support Team slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,120
    Vote Rating
    227
    slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of

      0  

    Default

    Yeah, I just tested, too, before I saw your post. I can use create/widget in 4.0.7, but it fails in 4.1 B3.

    *See also: http://www.sencha.com/forum/showthre...er-not-working
    - EXTJSIV-5123

  5. #5
    Sencha Premium Member skirtle's Avatar
    Join Date
    Oct 2010
    Location
    UK
    Posts
    3,784
    Vote Rating
    379
    skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute skirtle has a reputation beyond repute

      0  

    Default

    Moved to the bugs forum.

  6. #6
    Sencha - Support Team slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,120
    Vote Rating
    227
    slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of

      0  

    Default

    FWIW this is still broken in 4.1 RC1.

  7. #7
    Sencha - Support Team slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,120
    Vote Rating
    227
    slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of

      0  

    Default

    This appears to be working ok in 4.1.1 RC1 (or before).
    Is is possible to mark this thread as Fixed?

Thread Participants: 2