Results 1 to 5 of 5

Thread: Sencha Touch 2.x : Blank White Screen Loading only after Splash Screen.

  1. #1
    Sencha User
    Join Date
    Nov 2011
    Posts
    13
    Vote Rating
    0
      0  

    Default Answered: Sencha Touch 2.x : Blank White Screen Loading only after Splash Screen.

    Hi,

    In my applications I have used sencha-touch-all.js from Sencha Touch 2.x. Its working well with all devices of Android OS and in Ipad also.

    But its not working in Iphone, When I load apps in the Iphone device its shows splash screen first then after only white blank screen only.

    I have searched and searching on for this issue but not find any respective answer that solve my query.

    Hopefully I post to get it fix out.

    Thanks in advance.

  2. YOu need to use a remote debugger like weinre to see if there are any errors that are happening.

  3. #2
    Sencha - Sr Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    39,551
    Answers
    3931
    Vote Rating
    1271
      0  

    Default

    YOu need to use a remote debugger like weinre to see if there are any errors that are happening.
    Mitchell Simoens @LikelyMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Learn BBCode and use it! Checkout the CODE tag!

    Check out my GitHub, lots of nice things for Ext JS and Sencha Touch
    https://github.com/mitchellsimoens

  4. #3
    Sencha User
    Join Date
    Feb 2012
    Posts
    5
    Vote Rating
    0
      0  

    Default

    weinre 1.6.1 doesn't work with sencha touch 2. https://issues.apache.org/jira/browse/CB-175

    Weinre does not work correctly on Android 2.3.3 :
    After only one correct log, i keep getting this error :

    01-16 12:33:56.196: E/Web Console(465): TypeError: Result of expression 'contentType' [null] is not an object. athttp://192.168.22.27:8080/target/tar...anonymous:2772
    and does not get any more log (only errors), app works & i get logs in eclipse logcat without weinre correctly.

  5. #4
    Sencha User
    Join Date
    Feb 2012
    Posts
    54
    Vote Rating
    0
      0  

    Default

    you can try iwebinspector too, it works already with iOS 5.1 http://www.iwebinspector.com/

  6. #5
    Sencha User
    Join Date
    Feb 2012
    Posts
    5
    Vote Rating
    0
      0  

    Default

    Thanks Rui Marinho, http://www.iwebinspector.com/ is very useful for debugging PhoneGap app in iOS Simulator, is there any tool like this works for Android Simulator? my app works fine in iOS simulator and iPhone, and it works fine in Android 2.3.3 simulator, but blank screen after splashscreen logo in some android device. how to debug it in the android device to find the problem?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •